# CVE-2026-22743: Server-Side Request Forgery via Filter Expression Keys in Neo4jVectorStore

> Attackers can inject Cypher code via filter keys in Spring AI Neo4j store, potentially executing arbitrary queries or accessing data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-7cj7-rcw6-p68v

## What is CVE-2026-22743?

CVE-2026-22743 is a high-severity code injection vulnerability in Spring AI, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring AI's spring-ai-neo4j-store contains a Cypher injection vulnerability in Neo4jVectorFilterExpressionConverter. When a user-controlled string is passed as a filter expression key in Neo4jVectorFilterExpressionConverter of spring-ai-neo4j-store, doKey() embeds the key into a backtick-delimited Cypher property accessor (node.`metadata.`) after stripping only double quotes, without escaping embedded backticks.This issue affects Spring AI: from 1.0.0 before 1.0.5, from 1.1.0 before 1.1.4.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-22743?

4 open source packages ship an affected version, including org.springframework.ai:spring-ai-neo4j-store. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.ai:spring-ai-neo4j-store` | Maven | From 1.0.0-M5 | 1.0.5 |
| `org.springframework.ai:spring-ai-neo4j-store` | Maven | From 1.0.0-M5 | 1.0.5 |
| `org.springframework.ai:spring-ai-neo4j-store` | Maven | From 1.1.0-M1 | 1.1.4 |
| `org.springframework.ai:spring-ai-neo4j-store` | Maven | From 1.1.0-M1 | 1.1.4 |

Products: Vmware Spring Ai.

## How do I fix CVE-2026-22743?

Upgrade org.springframework.ai:spring-ai-neo4j-store to a fixed version for your release line: 1.0.5 or 1.1.4.

## Is CVE-2026-22743 being exploited?

There is no known exploitation of CVE-2026-22743 in the wild and no public exploit code.

## Other vulnerabilities in Spring AI

- [CVE-2026-22738](https://insights.sbomify.com/CVE-2026-22738/): SpEL Injection via Unescaped Filter Key in SimpleVectorStore Leads to Remote Code Execution (critical 9.8)
- [CVE-2026-40978](https://insights.sbomify.com/CVE-2026-40978/): Spring AI has SQL Injection in CosmosDBVectorStore.doDelete() (high 8.8)
- [CVE-2026-22730](https://insights.sbomify.com/CVE-2026-22730/): CVE-2026-22730: SQL Injection in Spring AI MariaDBFilterExpressionConverter (high 8.8)
- [CVE-2026-47835](https://insights.sbomify.com/CVE-2026-47835/): Spring AI vector store metadata filtering to handle special characters in Elasticsearch, OpenSearch, and GemFire Vector Stores (high 8.6)
- [CVE-2026-41705](https://insights.sbomify.com/CVE-2026-41705/): Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22743 and fix it if it is affected.

What it is: CVE-2026-22743 is a high-severity code injection vulnerability in Spring AI, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22743 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.ai:spring-ai-neo4j-store (Maven): affected from 1.0.0-M5; fixed in 1.0.5
- org.springframework.ai:spring-ai-neo4j-store (Maven): affected from 1.0.0-M5; fixed in 1.0.5
- org.springframework.ai:spring-ai-neo4j-store (Maven): affected from 1.1.0-M1; fixed in 1.1.4
- org.springframework.ai:spring-ai-neo4j-store (Maven): affected from 1.1.0-M1; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22743/ (Markdown: https://insights.sbomify.com/CVE-2026-22743/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22743
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22743
- OSV: https://osv.dev/vulnerability/CVE-2026-22743

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22743/
Summaries are generated and may contain mistakes; the official description above is the record.
