# CVE-2026-22745: CVE-2026-22745 : Denial of service in static resource handling on Windows platforms

> Attackers can cause denial of service in Spring MVC or WebFlux applications serving static resources on Windows by sending slow-to-resolve requests.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** CLEANSTART-2026-XE63512, CLEANSTART-2026-YX18209, CLSA-2026-1780361409, CLSA-2026-1783299709, CLSA-2026-1784769525, ECHO-a697-514e-e23d, GHSA-6p4f-wcwh-5vvm, MINI-22h6-6rqq-mhp3, MINI-2c7r-88xx-hv76, MINI-45xv-38jm-xm87, MINI-6rm7-2cvf-rw9v, MINI-8wfg-76fj-cr5f, MINI-j6hm-vqrj-pwp6, MINI-qw4q-f4x8-5q76, MINI-rq2j-3jpq-wm4h, MINI-wg43-9x2g-h57h, ROOT-APP-MAVEN-CVE-2026-22745

## What is CVE-2026-22745?

CVE-2026-22745 is a medium-severity denial of service vulnerability in Vmware Spring Framework, published on 29 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring MVC and WebFlux applications are vulnerable to Denial of Service attacks when resolving static resources.

More precisely, an application can be vulnerable when all the following are true:

  *  the application is using Spring MVC or Spring WebFlux
  *  the application is serving static resources from the file system
  *  the application is running on a Windows platform

When all the conditions above are met, the attacker can send malicious requests that are slow to resolve and that can keep HTTP connections in use. This can cause a Denial of Service on the application.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-22745?

16 open source packages ship an affected version, including org.springframework:spring-webflux and org.springframework:spring-webmvc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-webflux` | Maven | All versions to 5.3.47 | None |
| `org.springframework:spring-webflux` | Maven | All versions to 5.3.47 | None |
| `org.springframework:spring-webflux` | Maven | From 6.1.0 to 6.1.26 | None |
| `org.springframework:spring-webflux` | Maven | From 6.1.0 to 6.1.26 | None |
| `org.springframework:spring-webflux` | Maven | From 6.2.0 | 6.2.18 |
| `org.springframework:spring-webflux` | Maven | From 6.2.0 | 6.2.18 |
| `org.springframework:spring-webflux` | Maven | From 7.0.0 | 7.0.7 |
| `org.springframework:spring-webflux` | Maven | From 7.0.0 | 7.0.7 |
| `org.springframework:spring-webmvc` | Maven | All versions to 5.3.47 | None |
| `org.springframework:spring-webmvc` | Maven | All versions to 5.3.47 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.1.0 to 6.1.26 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.1.0 to 6.1.26 | None |
| `org.springframework:spring-webmvc` | Maven | From 6.2.0 | 6.2.18 |
| `org.springframework:spring-webmvc` | Maven | From 6.2.0 | 6.2.18 |
| `org.springframework:spring-webmvc` | Maven | From 7.0.0 | 7.0.7 |
| `org.springframework:spring-webmvc` | Maven | From 7.0.0 | 7.0.7 |

Products: Vmware Spring Framework.

## How do I fix CVE-2026-22745?

Upgrade org.springframework:spring-webflux to a fixed version for your release line: 6.2.18 or 7.0.7.

## Is CVE-2026-22745 being exploited?

There is no known exploitation of CVE-2026-22745 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22745 and fix it if it is affected.

What it is: CVE-2026-22745 is a medium-severity denial of service vulnerability in Vmware Spring Framework, published on 29 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22745 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-webflux (Maven): affected all versions up to 5.3.47; no fix listed
- org.springframework:spring-webflux (Maven): affected all versions up to 5.3.47; no fix listed
- org.springframework:spring-webflux (Maven): affected from 6.1.0 up to 6.1.26; no fix listed
- org.springframework:spring-webflux (Maven): affected from 6.1.0 up to 6.1.26; no fix listed
- org.springframework:spring-webflux (Maven): affected from 6.2.0; fixed in 6.2.18
- org.springframework:spring-webflux (Maven): affected from 6.2.0; fixed in 6.2.18
- org.springframework:spring-webflux (Maven): affected from 7.0.0; fixed in 7.0.7
- org.springframework:spring-webflux (Maven): affected from 7.0.0; fixed in 7.0.7
- org.springframework:spring-webmvc (Maven): affected all versions up to 5.3.47; no fix listed
- org.springframework:spring-webmvc (Maven): affected all versions up to 5.3.47; no fix listed
- org.springframework:spring-webmvc (Maven): affected from 6.1.0 up to 6.1.26; no fix listed
- org.springframework:spring-webmvc (Maven): affected from 6.1.0 up to 6.1.26; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22745/ (Markdown: https://insights.sbomify.com/CVE-2026-22745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22745
- OSV: https://osv.dev/vulnerability/CVE-2026-22745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22745/
Summaries are generated and may contain mistakes; the official description above is the record.
