# CVE-2026-22746: User Attribute Enumeration when Using DaoAuthenticationProvider

> Attackers can enumerate disabled, expired, or locked user accounts by bypassing timing attack defenses in Spring Security when specific user attributes are used.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** CLEANSTART-2026-GO18294, CLEANSTART-2026-NC72499, CLSA-2026-1779238053, CLSA-2026-1779238057, CLSA-2026-1779324466, CLSA-2026-1779410899, CLSA-2026-1779670112, CLSA-2026-1779842934, CLSA-2026-1779929351, CLSA-2026-1781657691, CLSA-2026-1783040466, ECHO-f76b-7d58-17ae, GHSA-vxf7-qj7q-83fh, MINI-2mp3-8cc9-6f6j, MINI-3h39-8gmw-m53v, MINI-64pw-gjh2-q8g5, MINI-7mcf-926p-hvx7, MINI-7p6v-j7w7-829w, MINI-9xh5-38jf-44x8, MINI-f2c9-x62v-384q, MINI-f7rr-7gw2-wrxh, MINI-jw8h-g94q-rmxf, MINI-qgf5-5g4j-xwvv, MINI-w95g-jxc3-c6m6, MINI-wvm2-6xg2-pvr9, MINI-xffh-48qc-hcpx

## What is CVE-2026-22746?

CVE-2026-22746 is a low-severity vulnerability in Spring Security, published on 22 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in Spring Spring Security. If an application is using the UserDetails#isEnabled, #isAccountNonExpired, or #isAccountNonLocked user attributes, to enable, expire, or lock users, then DaoAuthenticationProvider's timing attack defense can be bypassed for users who are disabled, expired, or locked.This issue affects Spring Security: from 5.7.0 through 5.7.22, from 5.8.0 through 5.8.24, from 6.3.0 through 6.3.15, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-22746?

12 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 5.7.0 to 5.7.22 | None |
| `org.springframework.security:spring-security-core` | Maven | From 5.7.0 to 5.7.22 | None |
| `org.springframework.security:spring-security-core` | Maven | From 5.8.0 to 5.8.24 | None |
| `org.springframework.security:spring-security-core` | Maven | From 5.8.0 to 5.8.24 | None |
| `org.springframework.security:spring-security-core` | Maven | From 6.3.0 to 6.3.15 | None |
| `org.springframework.security:spring-security-core` | Maven | From 6.3.0 to 6.3.15 | None |
| `org.springframework.security:spring-security-core` | Maven | From 6.4.0 to 6.4.15 | None |
| `org.springframework.security:spring-security-core` | Maven | From 6.4.0 to 6.4.15 | None |
| `org.springframework.security:spring-security-core` | Maven | From 6.5.0 | 6.5.10 |
| `org.springframework.security:spring-security-core` | Maven | From 6.5.0 | 6.5.10 |
| `org.springframework.security:spring-security-core` | Maven | From 7.0.0 | 7.0.5 |
| `org.springframework.security:spring-security-core` | Maven | From 7.0.0 | 7.0.5 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-22746?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 6.5.10 or 7.0.5.

## Is CVE-2026-22746 being exploited?

There is no known exploitation of CVE-2026-22746 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22746 and fix it if it is affected.

What it is: CVE-2026-22746 is a low-severity vulnerability in Spring Security, published on 22 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22746 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 5.7.0 up to 5.7.22; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 5.7.0 up to 5.7.22; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 5.8.0 up to 5.8.24; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 5.8.0 up to 5.8.24; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 6.3.0 up to 6.3.15; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 6.3.0 up to 6.3.15; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 6.4.0 up to 6.4.15; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 6.4.0 up to 6.4.15; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 6.5.0; fixed in 6.5.10
- org.springframework.security:spring-security-core (Maven): affected from 6.5.0; fixed in 6.5.10
- org.springframework.security:spring-security-core (Maven): affected from 7.0.0; fixed in 7.0.5
- org.springframework.security:spring-security-core (Maven): affected from 7.0.0; fixed in 7.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22746/ (Markdown: https://insights.sbomify.com/CVE-2026-22746/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22746
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22746
- OSV: https://osv.dev/vulnerability/CVE-2026-22746

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22746/
Summaries are generated and may contain mistakes; the official description above is the record.
