# CVE-2026-22747: Unauthorized User Impersonation when Using X.509 Client Certificates

> Attackers can impersonate other users by exploiting malformed X.509 certificate handling in Spring Security when client certificate authentication is enabled.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-QH64443, CLSA-2026-1783645400, CLSA-2026-1790947292, GHSA-2jrg-rf5x-568g, MINI-2ww6-rqv3-7mx4, MINI-3xmj-69r2-6r9x, MINI-mmh5-g366-hwv4

## What is CVE-2026-22747?

CVE-2026-22747 is a medium-severity authentication bypass vulnerability in Spring Security, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vulnerability in Spring Spring Security. SubjectX500PrincipalExtractor does not correctly handle certain malformed X.509 certificate CN values, which can lead to reading the wrong value for the username. In a carefully crafted certificate, this can lead to an attacker impersonating another user.
This issue affects Spring Security: from 7.0.0 through 7.0.4.

Weakness: CWE-295 (Improper Certificate Validation), CWE-297 (Improper Validation of Certificate with Host Mismatch)

## Which versions are affected by CVE-2026-22747?

2 open source packages ship an affected version, including org.springframework.security:spring-security-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-web` | Maven | From 7.0.0 | 7.0.5 |
| `org.springframework.security:spring-security-web` | Maven | From 7.0.0 | 7.0.5 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-22747?

Upgrade org.springframework.security:spring-security-web to 7.0.5 or later.

## Is CVE-2026-22747 being exploited?

There is no known exploitation of CVE-2026-22747 in the wild and no public exploit code.

Public exploit code:

- https://github.com/gsadagopan/cve-2026-22747-sandbox (github_poc): https://github.com/gsadagopan/cve-2026-22747-sandbox
- Sprint Security 7.0.0 à 7.0.4 (github_poc): https://github.com/yakissa/CVE-2026-22747

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22747 and fix it if it is affected.

What it is: CVE-2026-22747 is a medium-severity authentication bypass vulnerability in Spring Security, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22747 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-web (Maven): affected from 7.0.0; fixed in 7.0.5
- org.springframework.security:spring-security-web (Maven): affected from 7.0.0; fixed in 7.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22747/ (Markdown: https://insights.sbomify.com/CVE-2026-22747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22747
- OSV: https://osv.dev/vulnerability/CVE-2026-22747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22747/
Summaries are generated and may contain mistakes; the official description above is the record.
