# CVE-2026-22748: Potential Security Misconfiguration when Using withIssuerLocation

> Developers using Spring Security JWT decoding may inadvertently omit token validation, leading to potential security bypasses if not explicitly configured.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** CLEANSTART-2026-FR51189, CLEANSTART-2026-KA19928, CLEANSTART-2026-OF60690, CLEANSTART-2026-VT93127, CLSA-2026-1786563390, ECHO-d5bb-3a59-47f3, GHSA-cvc6-q2cp-2xhw, MINI-7g76-2642-6wgx, MINI-gh43-442r-c35h, MINI-jj56-v8hg-jq84, ROOT-APP-MAVEN-CVE-2026-22748

## What is CVE-2026-22748?

CVE-2026-22748 is a medium-severity vulnerability in Spring Security, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vulnerability in Spring Spring Security. When an application configures JWT decoding with NimbusJwtDecoder  or NimbusReactiveJwtDecoder, it must configure an OAuth2TokenValidator<Jwt> separately, for example by calling setJwtValidator.This issue affects Spring Security: from 6.3.0 through 6.3.14, from 6.4.0 through 6.4.14, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-22748?

8 open source packages ship an affected version, including org.springframework.security:spring-security-oauth2-jose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 6.3.0 to 6.3.14 | None |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 6.3.0 to 6.3.14 | None |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 6.4.0 to 6.4.14 | None |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 6.4.0 to 6.4.14 | None |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 6.5.0 | 6.5.10 |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 6.5.0 | 6.5.10 |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 7.0.0 | 7.0.5 |
| `org.springframework.security:spring-security-oauth2-jose` | Maven | From 7.0.0 | 7.0.5 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-22748?

Upgrade org.springframework.security:spring-security-oauth2-jose to a fixed version for your release line: 6.5.10 or 7.0.5.

## Is CVE-2026-22748 being exploited?

There is no known exploitation of CVE-2026-22748 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22748 and fix it if it is affected.

What it is: CVE-2026-22748 is a medium-severity vulnerability in Spring Security, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22748 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 6.3.0 up to 6.3.14; no fix listed
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 6.3.0 up to 6.3.14; no fix listed
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 6.4.0 up to 6.4.14; no fix listed
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 6.4.0 up to 6.4.14; no fix listed
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 6.5.0; fixed in 6.5.10
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 6.5.0; fixed in 6.5.10
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 7.0.0; fixed in 7.0.5
- org.springframework.security:spring-security-oauth2-jose (Maven): affected from 7.0.0; fixed in 7.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22748/ (Markdown: https://insights.sbomify.com/CVE-2026-22748/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22748
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22748
- OSV: https://osv.dev/vulnerability/CVE-2026-22748

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22748/
Summaries are generated and may contain mistakes; the official description above is the record.
