# CVE-2026-22751: Spring Security JdbcOneTimeTokenService allows a one-time token to authenticate multiple sessions

> Attackers can reuse one-time tokens to authenticate multiple sessions due to a race condition in Spring Security's JdbcOneTimeTokenService.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** CLEANSTART-2026-GH15179, CLEANSTART-2026-WO51602, ECHO-44f0-ed43-bd18, GHSA-x2wq-9x2f-fhj7, MINI-273p-cjrj-584f, MINI-2xv4-m347-fr6j, MINI-6hrf-r235-p9mm, MINI-78fm-gjcg-2v2q, MINI-7mhr-c75m-pxqm, MINI-fpvw-g2c6-h6rq, MINI-g4g7-2vf3-w3v6, MINI-gj2q-69f6-j5vj, MINI-j32r-7rhp-v526, MINI-j566-xwpp-qx3c, MINI-vqfr-vwqf-rqpc, ROOT-APP-MAVEN-CVE-2026-22751

## What is CVE-2026-22751?

CVE-2026-22751 is a medium-severity vulnerability in Spring Security, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in Spring Spring Security. Applications that explicitly configure One-Time Token login with JdbcOneTimeTokenService are vulnerable to a Time-of-check Time-of-use (TOCTOU) race condition. This issue affects Spring Security: from 6.4.0 through 6.4.15, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-22751?

6 open source packages ship an affected version, including org.springframework.security:spring-security-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 6.4.0 to 6.4.13 | None |
| `org.springframework.security:spring-security-core` | Maven | From 6.4.0 to 6.4.13 | None |
| `org.springframework.security:spring-security-core` | Maven | From 6.5.0 | 6.5.10 |
| `org.springframework.security:spring-security-core` | Maven | From 6.5.0 | 6.5.10 |
| `org.springframework.security:spring-security-core` | Maven | From 7.0.3 | 7.0.5 |
| `org.springframework.security:spring-security-core` | Maven | From 7.0.3 | 7.0.5 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-22751?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 6.5.10 or 7.0.5.

## Is CVE-2026-22751 being exploited?

There is no known exploitation of CVE-2026-22751 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22751 and fix it if it is affected.

What it is: CVE-2026-22751 is a medium-severity vulnerability in Spring Security, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22751 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 6.4.0 up to 6.4.13; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 6.4.0 up to 6.4.13; no fix listed
- org.springframework.security:spring-security-core (Maven): affected from 6.5.0; fixed in 6.5.10
- org.springframework.security:spring-security-core (Maven): affected from 6.5.0; fixed in 6.5.10
- org.springframework.security:spring-security-core (Maven): affected from 7.0.3; fixed in 7.0.5
- org.springframework.security:spring-security-core (Maven): affected from 7.0.3; fixed in 7.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22751/ (Markdown: https://insights.sbomify.com/CVE-2026-22751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22751
- OSV: https://osv.dev/vulnerability/CVE-2026-22751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22751/
Summaries are generated and may contain mistakes; the official description above is the record.
