# CVE-2026-22753: Servlet Path Not Correctly Included in Path Matching of HttpSecurity#securityMatchers

> Attackers can bypass authentication and authorization controls in Spring Security applications using specific servlet path configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** CLEANSTART-2026-QI62351, GHSA-4wrg-8wpc-h923, MINI-54vr-rjwv-3j29, MINI-rrgh-qch9-6rcg, ROOT-APP-MAVEN-CVE-2026-22753

## What is CVE-2026-22753?

CVE-2026-22753 is a high-severity missing authorization vulnerability in Spring Security, published on 22 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in Spring Spring Security. If an application is using securityMatchers(String) and a PathPatternRequestMatcher.Builder bean to prepend a servlet path, matching requests to that filter chain may fail and its related security components will not be exercised as intended by the application. This can lead to the authentication, authorization, and other security controls being rendered inactive on intended requests.This issue affects Spring Security: from 7.0.0 through 7.0.4.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-22753?

2 open source packages ship an affected version, including org.springframework.security:spring-security-config. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-config` | Maven | From 7.0.0 | 7.0.5 |
| `org.springframework.security:spring-security-config` | Maven | From 7.0.0 | 7.0.5 |

Products: Vmware Spring Security.

## How do I fix CVE-2026-22753?

Upgrade org.springframework.security:spring-security-config to 7.0.5 or later.

## Is CVE-2026-22753 being exploited?

There is no known exploitation of CVE-2026-22753 in the wild and no public exploit code.

## Other vulnerabilities in Spring Security

- [CVE-2014-3527](https://insights.sbomify.com/CVE-2014-3527/): Authorization Bypass in Spring Security (critical 9.8)
- [CVE-2026-59354](https://insights.sbomify.com/CVE-2026-59354/): Spring Security OAuth2 Authorization Server: Insufficient validation of Dynamic Client Registration metadata (critical 9.6)
- [CVE-2026-59270](https://insights.sbomify.com/CVE-2026-59270/): Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces (critical 9.4)
- [CVE-2026-22732](https://insights.sbomify.com/CVE-2026-22732/): Under Some Conditions Spring Security HTTP Headers Are not Written (critical 9.1)
- [CVE-2023-34034](https://insights.sbomify.com/CVE-2023-34034/): Access Control Bypass in Spring Security (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22753 and fix it if it is affected.

What it is: CVE-2026-22753 is a high-severity missing authorization vulnerability in Spring Security, published on 22 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22753 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-config (Maven): affected from 7.0.0; fixed in 7.0.5
- org.springframework.security:spring-security-config (Maven): affected from 7.0.0; fixed in 7.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22753/ (Markdown: https://insights.sbomify.com/CVE-2026-22753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22753
- OSV: https://osv.dev/vulnerability/CVE-2026-22753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22753/
Summaries are generated and may contain mistakes; the official description above is the record.
