{"answers":{"affected":"6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22771 in the wild and no public exploit code.","fix":"Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.5.7 or 1.6.2.","what":"CVE-2026-22771 is a high-severity code injection vulnerability in envoyproxy gateway, published on 12 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22771 and fix it if it is affected.\n\nWhat it is: CVE-2026-22771 is a high-severity code injection vulnerability in envoyproxy gateway, published on 12 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-22771 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.5.7, 1.6.2\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.5.7\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.5.7\n- github.com/envoyproxy/gateway (Go): affected from 1.6.0-rc.0; fixed in 1.6.2\n- github.com/envoyproxy/gateway (Go): affected from 1.6.0-rc.0; fixed in 1.6.2\n- envoy-gateway (Bitnami): affected all versions; fixed in 1.5.7, 1.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22771/ (Markdown: https://insights.sbomify.com/CVE-2026-22771/index.md)","id":"CVE-2026-22771","markdown":"https://insights.sbomify.com/CVE-2026-22771/index.md","name":"CVE-2026-22771","record":{"aliases":["BIT-envoy-gateway-2026-22771","CLEANSTART-2026-MY21105","CLEANSTART-2026-TM34060","GHSA-xrwg-mqj6-6m22","GO-2026-4312","MINI-57xr-9vc7-9pr9","MINI-rm85-wjmf-wg96"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Envoy Gateway","requires_auth":"low_privilege","summary":"Attackers can inject Lua scripts into Envoy Extension Policies to execute arbitrary commands and steal proxy credentials, exposing sensitive secrets.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gateway","vendor":"envoyproxy"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.5.7 and 1.6.2, EnvoyExtensionPolicy Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. This vulnerability is fixed in 1.5.7 and 1.6.2.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Envoy Extension Policy lua scripts injection causes arbitrary command execution","id":"CVE-2026-22771","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"Fulcio vulnerable to Server-Side Request Forgery (SSRF) via MetaIssuer Regex Bypass","id":"CVE-2026-22772"},"packages":[{"ecosystem":"Bitnami","fixed":["1.5.7","1.6.2"],"introduced":["0","1.6.0"],"last_affected":[],"package":"envoy-gateway","purl":"pkg:bitnami/envoy-gateway","source":"BIT-envoy-gateway-2026-22771"},{"ecosystem":"Go","fixed":["1.5.7","1.6.2"],"introduced":["0","1.6.0-rc.0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GO-2026-4312"},{"ecosystem":"Go","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":null,"source":"GHSA-xrwg-mqj6-6m22"},{"ecosystem":"Go","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GHSA-xrwg-mqj6-6m22"},{"ecosystem":"Go","fixed":["1.6.2"],"introduced":["1.6.0-rc.0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":null,"source":"GHSA-xrwg-mqj6-6m22"},{"ecosystem":"Go","fixed":["1.6.2"],"introduced":["1.6.0-rc.0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GHSA-xrwg-mqj6-6m22"}],"prev":{"headline":"ImageMagick vulnerable to Release of Invalid Pointer in BilateralBlur when memory allocation fails","id":"CVE-2026-22770"},"products":["gateway"],"published":"2026-01-12","related":[{"cvss_score":7.1,"headline":"Envoy Admin Interface Exposed through prometheus metrics endpoint","id":"CVE-2025-24030","kev_date_added":null,"published":"2025-01-23"},{"cvss_score":5.3,"headline":"Envoy Gateway Log Injection Vulnerability","id":"CVE-2025-25294","kev_date_added":null,"published":"2025-03-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["envoyproxy"]},"summary":"Attackers can inject Lua scripts into Envoy Extension Policies to execute arbitrary commands and steal proxy credentials, exposing sensitive secrets.","url":"https://insights.sbomify.com/CVE-2026-22771/"}