# CVE-2026-22771: Envoy Extension Policy lua scripts injection causes arbitrary command execution

> Attackers can inject Lua scripts into Envoy Extension Policies to execute arbitrary commands and steal proxy credentials, exposing sensitive secrets.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-envoy-gateway-2026-22771, CLEANSTART-2026-MY21105, CLEANSTART-2026-TM34060, GHSA-xrwg-mqj6-6m22, GO-2026-4312, MINI-57xr-9vc7-9pr9, MINI-rm85-wjmf-wg96

## What is CVE-2026-22771?

CVE-2026-22771 is a high-severity code injection vulnerability in envoyproxy gateway, published on 12 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.5.7 and 1.6.2, EnvoyExtensionPolicy Lua scripts executed by Envoy proxy can be used to leak the proxy's credentials. These credentials can then be used to communicate with the control plane and gain access to all secrets that are used by Envoy proxy, e.g. TLS private keys and credentials used for downstream and upstream communication. This vulnerability is fixed in 1.5.7 and 1.6.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-22771?

6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.5.7, 1.6.2 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.5.7 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.5.7 |
| `github.com/envoyproxy/gateway` | Go | From 1.6.0-rc.0 | 1.6.2 |
| `github.com/envoyproxy/gateway` | Go | From 1.6.0-rc.0 | 1.6.2 |
| `envoy-gateway` | Bitnami | All versions | 1.5.7, 1.6.2 |

Products: Envoyproxy Gateway.

## How do I fix CVE-2026-22771?

Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.5.7 or 1.6.2.

## Is CVE-2026-22771 being exploited?

There is no known exploitation of CVE-2026-22771 in the wild and no public exploit code.

## Other vulnerabilities in envoyproxy gateway

- [CVE-2025-24030](https://insights.sbomify.com/CVE-2025-24030/): Envoy Admin Interface Exposed through prometheus metrics endpoint (high 7.1)
- [CVE-2025-25294](https://insights.sbomify.com/CVE-2025-25294/): Envoy Gateway Log Injection Vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22771 and fix it if it is affected.

What it is: CVE-2026-22771 is a high-severity code injection vulnerability in envoyproxy gateway, published on 12 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22771 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.5.7, 1.6.2
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.5.7
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.5.7
- github.com/envoyproxy/gateway (Go): affected from 1.6.0-rc.0; fixed in 1.6.2
- github.com/envoyproxy/gateway (Go): affected from 1.6.0-rc.0; fixed in 1.6.2
- envoy-gateway (Bitnami): affected all versions; fixed in 1.5.7, 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22771/ (Markdown: https://insights.sbomify.com/CVE-2026-22771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22771
- OSV: https://osv.dev/vulnerability/CVE-2026-22771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22771/
Summaries are generated and may contain mistakes; the official description above is the record.
