# CVE-2026-22772: Fulcio vulnerable to Server-Side Request Forgery (SSRF) via MetaIssuer Regex Bypass

> Attackers can bypass URL validation to trigger blind SSRF against internal services, enabling network probing without data exfiltration or state mutation.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** CLEANSTART-2026-LN74162, CLEANSTART-2026-NY15561, DEBIAN-CVE-2026-22772, GHSA-59jp-pj84-45mr, GO-2026-4311, MINI-392x-774v-f573, MINI-3p4w-m66q-wc8v, MINI-47q3-hvq2-3cr4, MINI-52j5-78jc-jgc3, MINI-5m8v-x4gc-qf6h, MINI-5w7j-cp65-cg7v, MINI-6xc7-x6cg-9vgp, MINI-77g9-jw3g-fj29, MINI-9wcm-mqmc-7jgm, MINI-c34w-rh7w-x63c, MINI-f62w-xj5g-r84r, MINI-h2mq-whpp-727q, MINI-hgqj-jqpv-qqch, MINI-mjgh-xw58-xr2x, MINI-q7vr-39q9-6cvg, MINI-qgc8-69p4-7gx2, MINI-rp77-fv92-wjv9, MINI-v4rf-3x5f-8x3w, MINI-w4gq-82rw-3534, MINI-wg88-xmp6-m4jf, MINI-ww59-c7q4-jw2c, MINI-x482-4g5f-qvcq, MINI-x76v-f959-v749, MINI-xpp4-34hj-87w4, MINI-xqjw-jx9f-2fr8, UBUNTU-CVE-2026-22772, openSUSE-RU-2026:20161-1, openSUSE-SU-2026:10068-1

## What is CVE-2026-22772?

CVE-2026-22772 is a medium-severity server-side request forgery vulnerability in sigstore fulcio, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fulcio is a certificate authority for issuing code signing certificates for an OpenID Connect (OIDC) identity. Prior to 1.8.5, Fulcio's metaRegex() function uses unanchored regex, allowing attackers to bypass MetaIssuer URL validation and trigger SSRF to arbitrary internal services. Since the SSRF only can trigger GET requests, the request cannot mutate state. The response from the GET request is not returned to the caller so data exfiltration is not possible. A malicious actor could attempt to probe an internal network through Blind SSRF. This vulnerability is fixed in 1.8.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-22772?

3 open source packages ship an affected version, including github.com/sigstore/fulcio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/fulcio` | Go | All versions | 1.8.5 |
| `github.com/sigstore/fulcio` | Go | All versions | 1.8.5 |
| `github.com/sigstore/fulcio` | Go | All versions | 1.8.5 |
| `hauler` | openSUSE:Leap 16.0 | All versions | 1.4.1-bp160.1.1 |
| `hauler` | openSUSE:Tumbleweed | All versions | 1.4.1-1.1 |

Products: Linuxfoundation Fulcio.

## How do I fix CVE-2026-22772?

Upgrade github.com/sigstore/fulcio to 1.8.5 or later.

## Is CVE-2026-22772 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22772 exists.

## Other vulnerabilities in sigstore fulcio

- [CVE-2025-66506](https://insights.sbomify.com/CVE-2025-66506/): Fulcio allocates excessive memory during token parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22772 and fix it if it is affected.

What it is: CVE-2026-22772 is a medium-severity server-side request forgery vulnerability in sigstore fulcio, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22772 exists.

Affected packages and fixed versions:
- github.com/sigstore/fulcio (Go): affected all versions; fixed in 1.8.5
- github.com/sigstore/fulcio (Go): affected all versions; fixed in 1.8.5
- github.com/sigstore/fulcio (Go): affected all versions; fixed in 1.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22772/ (Markdown: https://insights.sbomify.com/CVE-2026-22772/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22772
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22772
- OSV: https://osv.dev/vulnerability/CVE-2026-22772

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22772/
Summaries are generated and may contain mistakes; the official description above is the record.
