CVE-2026-22773 vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous dimensions

Medium 6.5 Published Updated

Attackers can crash the vLLM server by sending a crafted 1x1 pixel image to Idefics3 vision models, causing a tensor dimension mismatch.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-22773?

CVE-2026-22773 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 10 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.

Weakness: CWE-770

Which versions are affected by CVE-2026-22773?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.6.40.12.0
vllm PyPIFrom 0.6.40.12.0
vllm PyPIFrom 0.6.40.12.0

Products include Vllm Vllm.

How do I fix CVE-2026-22773?

Upgrade vllm to 0.12.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-22773 being exploited?

There is no known exploitation of CVE-2026-22773 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-grg2-63fw-f2qr, PYSEC-2026-143.

Is CVE-2026-22773 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free