# CVE-2026-22773: vLLM is vulnerable to DoS in Idefics3 vision models via image payload with ambiguous dimensions

> Attackers can crash the vLLM server by sending a crafted 1x1 pixel image to Idefics3 vision models, causing a tensor dimension mismatch.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-grg2-63fw-f2qr, PYSEC-2026-143

## What is CVE-2026-22773?

CVE-2026-22773 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 10 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-22773?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.6.4 | 0.12.0 |
| `vllm` | PyPI | From 0.6.4 | 0.12.0 |
| `vllm` | PyPI | From 0.6.4 | 0.12.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-22773?

Upgrade vllm to 0.12.0 or later.

## Is CVE-2026-22773 being exploited?

There is no known exploitation of CVE-2026-22773 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22773 and fix it if it is affected.

What it is: CVE-2026-22773 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 10 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22773 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.6.4; fixed in 0.12.0
- vllm (PyPI): affected from 0.6.4; fixed in 0.12.0
- vllm (PyPI): affected from 0.6.4; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22773/ (Markdown: https://insights.sbomify.com/CVE-2026-22773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22773
- OSV: https://osv.dev/vulnerability/CVE-2026-22773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22773/
Summaries are generated and may contain mistakes; the official description above is the record.
