# CVE-2026-22774: devalue vulnerable to denial of service due to memory exhaustion in devalue.parse

> Attackers can cause denial of service via memory exhaustion in devalue.parse when processing untrusted input, affecting applications using this JavaScript library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-vw5p-8cq8-m7mv

## What is CVE-2026-22774?

CVE-2026-22774 is a high-severity denial of service vulnerability in sveltejs devalue, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.3.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the typed array hydration expecting an ArrayBuffer as input, but not checking the assumption before creating the typed array. This vulnerability is fixed in 5.6.2.

Weakness: CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2026-22774?

2 open source packages ship an affected version, including devalue. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devalue` | npm | From 5.3.0 | 5.6.2 |
| `devalue` | npm | From 5.3.0 | 5.6.2 |

Products: Svelte Devalue.

## How do I fix CVE-2026-22774?

Upgrade devalue to 5.6.2 or later.

## Is CVE-2026-22774 being exploited?

There is no known exploitation of CVE-2026-22774 in the wild and no public exploit code.

## Other vulnerabilities in sveltejs devalue

- [CVE-2026-42570](https://insights.sbomify.com/CVE-2026-42570/): Svelte devalue: DoS via sparse array deserialization (high 7.5)
- [CVE-2026-22775](https://insights.sbomify.com/CVE-2026-22775/): devalue vulnerable to denial of service due to memory/CPU exhaustion in devalue.parse (high 7.5)
- [CVE-2026-30226](https://insights.sbomify.com/CVE-2026-30226/): devalue has prototype pollution in devalue.parse and devalue.unflatten (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22774 and fix it if it is affected.

What it is: CVE-2026-22774 is a high-severity denial of service vulnerability in sveltejs devalue, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22774 in the wild and no public exploit code.

Affected packages and fixed versions:
- devalue (npm): affected from 5.3.0; fixed in 5.6.2
- devalue (npm): affected from 5.3.0; fixed in 5.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22774/ (Markdown: https://insights.sbomify.com/CVE-2026-22774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22774
- OSV: https://osv.dev/vulnerability/CVE-2026-22774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22774/
Summaries are generated and may contain mistakes; the official description above is the record.
