CVE-2026-22775 devalue vulnerable to denial of service due to memory/CPU exhaustion in devalue.parse
Attackers can cause denial of service via CPU or memory exhaustion in devalue.parse when processing untrusted input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-22775?
CVE-2026-22775 is a high-severity denial of service vulnerability in sveltejs devalue, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.1.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the ArrayBuffer hydration expecting base64 encoded strings as input, but not checking the assumption before decoding the input. This vulnerability is fixed in 5.6.2.
Weakness: CWE-405
Which versions are affected by CVE-2026-22775?
2 open source packages ship an affected version, including devalue. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
devalue npm | From 5.1.0 | 5.6.2 |
devalue npm | From 5.1.0 | 5.6.2 |
Products include Svelte Devalue.
How do I fix CVE-2026-22775?
Upgrade devalue to 5.6.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-22775 being exploited?
There is no known exploitation of CVE-2026-22775 in the wild and no public exploit code.
Other vulnerabilities in sveltejs devalue
Sources
Also known as GHSA-g2pg-6438-jwpf.