CVE-2026-22777 ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler
Attackers can inject characters into HTTP parameters to tamper with configuration files, altering application behavior or security settings.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-22777?
CVE-2026-22777 is a high-severity vulnerability in Comfy-Org ComfyUI-Manager, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ComfyUI-Manager is an extension designed to enhance the usability of ComfyUI. Prior to versions 3.39.2 and 4.0.5, an attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior. This issue has been patched in versions 3.39.2 and 4.0.5.
Weakness: CWE-93
Which versions are affected by CVE-2026-22777?
5 open source packages ship an affected version, including comfy-cli. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
comfy-cli PyPI | All versions | 3.39.2, 4.0.5 |
comfy-cli PyPI | All versions | 3.39.2 |
comfy-cli PyPI | All versions | 3.39.2 |
comfy-cli PyPI | From 4.0.0 | 4.0.5 |
comfy-cli PyPI | From 4.0.0 | 4.0.5 |
Products include Comfy Comfyui-Manager.
How do I fix CVE-2026-22777?
Upgrade comfy-cli to a fixed version for your release line: 3.39.2 or 4.0.5.
Is CVE-2026-22777 being exploited?
There is no known exploitation of CVE-2026-22777 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Comfy-Org ComfyUI-Manager
Sources
Also known as GHSA-562r-8445-54r2, PYSEC-2026-1260.