{"answers":{"affected":"5 open source packages ship an affected version, including comfy-cli. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22777 in the wild and no public exploit code.","fix":"Upgrade comfy-cli to a fixed version for your release line: 3.39.2 or 4.0.5.","what":"CVE-2026-22777 is a high-severity vulnerability in Comfy-Org ComfyUI-Manager, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22777 and fix it if it is affected.\n\nWhat it is: CVE-2026-22777 is a high-severity vulnerability in Comfy-Org ComfyUI-Manager, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-22777 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- comfy-cli (PyPI): affected all versions; fixed in 3.39.2, 4.0.5\n- comfy-cli (PyPI): affected all versions; fixed in 3.39.2\n- comfy-cli (PyPI): affected all versions; fixed in 3.39.2\n- comfy-cli (PyPI): affected from 4.0.0; fixed in 4.0.5\n- comfy-cli (PyPI): affected from 4.0.0; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22777/ (Markdown: https://insights.sbomify.com/CVE-2026-22777/index.md)","id":"CVE-2026-22777","markdown":"https://insights.sbomify.com/CVE-2026-22777/index.md","name":"CVE-2026-22777","record":{"aliases":["GHSA-562r-8445-54r2","PYSEC-2026-1260"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ComfyUI extension","requires_auth":"none","summary":"Attackers can inject characters into HTTP parameters to tamper with configuration files, altering application behavior or security settings.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"comfyui-manager","vendor":"comfy"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-93","name":"Improper Neutralization of CRLF Sequences"}],"description":"ComfyUI-Manager is an extension designed to enhance the usability of ComfyUI. Prior to versions 3.39.2 and 4.0.5, an attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior. This issue has been patched in versions 3.39.2 and 4.0.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-09-28","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-28T10:09:06Z","kind":"github_poc","ref":"https://github.com/Si13NTTT/CVE-2026-22777","stars":0,"title":"CVE-2026-22777 ComfyUI-Manager CRLF Injection leading to RCE chained with CVE-2025-67303"}],"tier":"poc_unverified"},"has_fix":true,"headline":"ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler","id":"CVE-2026-22777","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2026"},"n_packages":5,"n_references":2,"next":{"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778"},"packages":[{"ecosystem":"PyPI","fixed":["3.39.2","4.0.5"],"introduced":["0","4.0.0"],"last_affected":[],"package":"comfy-cli","purl":"pkg:pypi/comfy-cli","source":"PYSEC-2026-1260"},{"ecosystem":"PyPI","fixed":["3.39.2"],"introduced":["0"],"last_affected":[],"package":"comfy-cli","purl":null,"source":"GHSA-562r-8445-54r2"},{"ecosystem":"PyPI","fixed":["3.39.2"],"introduced":["0"],"last_affected":[],"package":"comfy-cli","purl":"pkg:pypi/comfy-cli","source":"GHSA-562r-8445-54r2"},{"ecosystem":"PyPI","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"comfy-cli","purl":null,"source":"GHSA-562r-8445-54r2"},{"ecosystem":"PyPI","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"comfy-cli","purl":"pkg:pypi/comfy-cli","source":"GHSA-562r-8445-54r2"}],"prev":{"headline":"cpp-httplib vulnerable to a denial of service (DOS) using a zip bomb","id":"CVE-2026-22776"},"products":["ComfyUI-Manager"],"published":"2026-01-10","related":[{"cvss_score":7.5,"headline":"ComfyUI-Manager has an Unprotected Alternate Channel (CWE-420)","id":"CVE-2025-67303","kev_date_added":null,"published":"2026-01-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-12","vendors":["Comfy-Org"]},"summary":"Attackers can inject characters into HTTP parameters to tamper with configuration files, altering application behavior or security settings.","url":"https://insights.sbomify.com/CVE-2026-22777/"}