# CVE-2026-22777: ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler

> Attackers can inject characters into HTTP parameters to tamper with configuration files, altering application behavior or security settings.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2026
- **Updated:** 12 Jan 2026
- **Also known as:** GHSA-562r-8445-54r2, PYSEC-2026-1260

## What is CVE-2026-22777?

CVE-2026-22777 is a high-severity vulnerability in Comfy-Org ComfyUI-Manager, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ComfyUI-Manager is an extension designed to enhance the usability of ComfyUI. Prior to versions 3.39.2 and 4.0.5, an attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior. This issue has been patched in versions 3.39.2 and 4.0.5.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-22777?

5 open source packages ship an affected version, including comfy-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `comfy-cli` | PyPI | All versions | 3.39.2, 4.0.5 |
| `comfy-cli` | PyPI | All versions | 3.39.2 |
| `comfy-cli` | PyPI | All versions | 3.39.2 |
| `comfy-cli` | PyPI | From 4.0.0 | 4.0.5 |
| `comfy-cli` | PyPI | From 4.0.0 | 4.0.5 |

Products: Comfy Comfyui-Manager.

## How do I fix CVE-2026-22777?

Upgrade comfy-cli to a fixed version for your release line: 3.39.2 or 4.0.5.

## Is CVE-2026-22777 being exploited?

There is no known exploitation of CVE-2026-22777 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-22777 ComfyUI-Manager CRLF Injection leading to RCE chained with CVE-2025-67303 (github_poc): https://github.com/Si13NTTT/CVE-2026-22777

## Other vulnerabilities in Comfy-Org ComfyUI-Manager

- [CVE-2025-67303](https://insights.sbomify.com/CVE-2025-67303/): ComfyUI-Manager has an Unprotected Alternate Channel (CWE-420) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22777 and fix it if it is affected.

What it is: CVE-2026-22777 is a high-severity vulnerability in Comfy-Org ComfyUI-Manager, published on 10 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22777 in the wild and no public exploit code.

Affected packages and fixed versions:
- comfy-cli (PyPI): affected all versions; fixed in 3.39.2, 4.0.5
- comfy-cli (PyPI): affected all versions; fixed in 3.39.2
- comfy-cli (PyPI): affected all versions; fixed in 3.39.2
- comfy-cli (PyPI): affected from 4.0.0; fixed in 4.0.5
- comfy-cli (PyPI): affected from 4.0.0; fixed in 4.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22777/ (Markdown: https://insights.sbomify.com/CVE-2026-22777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22777
- OSV: https://osv.dev/vulnerability/CVE-2026-22777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22777/
Summaries are generated and may contain mistakes; the official description above is the record.
