CVE-2026-22778 vLLM leaks a heap address when PIL throws an error

Critical 9.8 Published Updated

vLLM leaks heap addresses via error messages, reducing ASLR effectiveness and enabling remote code execution when chained with other vulnerabilities.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-22778?

CVE-2026-22778 is a critical vulnerability in Vllm Vllm, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.

Weakness: CWE-209, CWE-532

Which versions are affected by CVE-2026-22778?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.8.30.14.1
vllm PyPIFrom 0.8.30.14.1
vllm PyPIFrom 0.8.30.14.1

Products include Vllm Vllm.

How do I fix CVE-2026-22778?

Upgrade vllm to 0.14.1 or later.

Is CVE-2026-22778 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22778 exists.

Public exploit code: 1 Metasploit module, 1 Nuclei template and 1 proofs of concept on GitHub.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-4r2x-xpjr-7cvv, PYSEC-2026-565.

Is CVE-2026-22778 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free