{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22778 exists.","fix":"Upgrade vllm to 0.14.1 or later.","what":"CVE-2026-22778 is a critical vulnerability in Vllm Vllm, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-22778 and fix it if it is affected.\n\nWhat it is: CVE-2026-22778 is a critical vulnerability in Vllm Vllm, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22778 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.8.3; fixed in 0.14.1\n- vllm (PyPI): affected from 0.8.3; fixed in 0.14.1\n- vllm (PyPI): affected from 0.8.3; fixed in 0.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22778/ (Markdown: https://insights.sbomify.com/CVE-2026-22778/index.md)","id":"CVE-2026-22778","markdown":"https://insights.sbomify.com/CVE-2026-22778/index.md","name":"CVE-2026-22778","record":{"aliases":["GHSA-4r2x-xpjr-7cvv","PYSEC-2026-565"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"none","summary":"vLLM leaks heap addresses via error messages, reducing ASLR effectiveness and enabling remote code execution when chained with other vulnerabilities.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"},{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-02-02","github_poc":1,"max_poc_stars":0,"metasploit":1,"nuclei":1,"refs":[{"date":"2026-02-02","kind":"metasploit","ref":"auxiliary/scanner/http/vllm_multimodal_info_leak","stars":null,"title":"vLLM Multimodal Heap-Address Information Leak Scanner"},{"date":"2026-09-05T03:52:07Z","kind":"github_poc","ref":"https://github.com/joaovicdev/EXPLOIT-CVE-2026-22778","stars":0,"title":null},{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-22778.yaml","stars":null,"title":"vLLM 0.8.3 - 0.14.0 - Information Disclosure"}],"tier":"weaponised"},"has_fix":true,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"BlackSheep ClientSession is vulnerable to CRLF injection","id":"CVE-2026-22779"},"packages":[{"ecosystem":"PyPI","fixed":["0.14.1"],"introduced":["0.8.3"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-4r2x-xpjr-7cvv"},{"ecosystem":"PyPI","fixed":["0.14.1"],"introduced":["0.8.3"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-4r2x-xpjr-7cvv"},{"ecosystem":"PyPI","fixed":["0.14.1"],"introduced":["0.8.3"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-565"}],"prev":{"headline":"ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler","id":"CVE-2026-22777"},"products":["vllm"],"published":"2026-02-02","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["vllm-project"]},"summary":"vLLM leaks heap addresses via error messages, reducing ASLR effectiveness and enabling remote code execution when chained with other vulnerabilities.","url":"https://insights.sbomify.com/CVE-2026-22778/"}