# CVE-2026-22778: vLLM leaks a heap address when PIL throws an error

> vLLM leaks heap addresses via error messages, reducing ASLR effectiveness and enabling remote code execution when chained with other vulnerabilities.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-4r2x-xpjr-7cvv, PYSEC-2026-565

## What is CVE-2026-22778?

CVE-2026-22778 is a critical vulnerability in Vllm Vllm, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-22778?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.8.3 | 0.14.1 |
| `vllm` | PyPI | From 0.8.3 | 0.14.1 |
| `vllm` | PyPI | From 0.8.3 | 0.14.1 |

Products: Vllm Vllm.

## How do I fix CVE-2026-22778?

Upgrade vllm to 0.14.1 or later.

## Is CVE-2026-22778 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22778 exists.

Public exploit code:

- vLLM Multimodal Heap-Address Information Leak Scanner (metasploit)
- https://github.com/joaovicdev/EXPLOIT-CVE-2026-22778 (github_poc): https://github.com/joaovicdev/EXPLOIT-CVE-2026-22778
- vLLM 0.8.3 - 0.14.0 - Information Disclosure (nuclei): http/cves/2026/CVE-2026-22778.yaml

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)
- [CVE-2025-29783](https://insights.sbomify.com/CVE-2025-29783/): vLLM Allows Remote Code Execution via Mooncake Integration (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22778 and fix it if it is affected.

What it is: CVE-2026-22778 is a critical vulnerability in Vllm Vllm, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22778 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.8.3; fixed in 0.14.1
- vllm (PyPI): affected from 0.8.3; fixed in 0.14.1
- vllm (PyPI): affected from 0.8.3; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22778/ (Markdown: https://insights.sbomify.com/CVE-2026-22778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22778
- OSV: https://osv.dev/vulnerability/CVE-2026-22778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22778/
Summaries are generated and may contain mistakes; the official description above is the record.
