{"answers":{"affected":"2 open source packages ship an affected version, including html2pdf.js. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22787 exists.","fix":"Upgrade html2pdf.js to 0.14.0 or later.","what":"CVE-2026-22787 is a high-severity cross-site scripting vulnerability in eKoopmans html2pdf.js, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-22787 and fix it if it is affected.\n\nWhat it is: CVE-2026-22787 is a high-severity cross-site scripting vulnerability in eKoopmans html2pdf.js, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22787 exists.\n\nAffected packages and fixed versions:\n- html2pdf.js (npm): affected all versions; fixed in 0.14.0\n- html2pdf.js (npm): affected all versions; fixed in 0.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22787/ (Markdown: https://insights.sbomify.com/CVE-2026-22787/index.md)","id":"CVE-2026-22787","markdown":"https://insights.sbomify.com/CVE-2026-22787/index.md","name":"CVE-2026-22787","record":{"aliases":["GHSA-w8x4-x68c-m6fc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript PDF library","requires_auth":"none","summary":"An XSS vulnerability in html2pdf.js allows attackers to execute malicious scripts via unsanitized text input, compromising client-side data integrity and confidentiality.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"html2pdf.js","vendor":"ekoopmans"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"html2pdf.js converts any webpage or element into a printable PDF entirely client-side. Prior to 0.14.0, html2pdf.js contains a cross-site scripting (XSS) vulnerability when given a text source rather than an element. This text is not sufficiently sanitized before being attached to the DOM, allowing malicious scripts to be run on the client browser and risking the confidentiality, integrity, and availability of the page's data. This vulnerability has been fixed in html2pdf.js@0.14.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"html2pdf.js has a cross-site scripting vulnerability","id":"CVE-2026-22787","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"WebErpMesv2 allows unauthenticated API Access","id":"CVE-2026-22788"},"packages":[{"ecosystem":"npm","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"html2pdf.js","purl":null,"source":"GHSA-w8x4-x68c-m6fc"},{"ecosystem":"npm","fixed":["0.14.0"],"introduced":["0"],"last_affected":[],"package":"html2pdf.js","purl":"pkg:npm/html2pdf.js","source":"GHSA-w8x4-x68c-m6fc"}],"prev":{"headline":"Gin-vue-admin has arbitrary file upload vulnerability caused by path traversal","id":"CVE-2026-22786"},"products":["html2pdf.js"],"published":"2026-01-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-20","vendors":["eKoopmans"]},"summary":"An XSS vulnerability in html2pdf.js allows attackers to execute malicious scripts via unsanitized text input, compromising client-side data integrity and confidentiality.","url":"https://insights.sbomify.com/CVE-2026-22787/"}