# CVE-2026-22787: html2pdf.js has a cross-site scripting vulnerability

> An XSS vulnerability in html2pdf.js allows attackers to execute malicious scripts via unsanitized text input, compromising client-side data integrity and confidentiality.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-w8x4-x68c-m6fc

## What is CVE-2026-22787?

CVE-2026-22787 is a high-severity cross-site scripting vulnerability in eKoopmans html2pdf.js, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

html2pdf.js converts any webpage or element into a printable PDF entirely client-side. Prior to 0.14.0, html2pdf.js contains a cross-site scripting (XSS) vulnerability when given a text source rather than an element. This text is not sufficiently sanitized before being attached to the DOM, allowing malicious scripts to be run on the client browser and risking the confidentiality, integrity, and availability of the page's data. This vulnerability has been fixed in html2pdf.js@0.14.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-22787?

2 open source packages ship an affected version, including html2pdf.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html2pdf.js` | npm | All versions | 0.14.0 |
| `html2pdf.js` | npm | All versions | 0.14.0 |

Products: Ekoopmans Html2pdf.js.

## How do I fix CVE-2026-22787?

Upgrade html2pdf.js to 0.14.0 or later.

## Is CVE-2026-22787 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22787 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22787 and fix it if it is affected.

What it is: CVE-2026-22787 is a high-severity cross-site scripting vulnerability in eKoopmans html2pdf.js, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22787 exists.

Affected packages and fixed versions:
- html2pdf.js (npm): affected all versions; fixed in 0.14.0
- html2pdf.js (npm): affected all versions; fixed in 0.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22787/ (Markdown: https://insights.sbomify.com/CVE-2026-22787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22787
- OSV: https://osv.dev/vulnerability/CVE-2026-22787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22787/
Summaries are generated and may contain mistakes; the official description above is the record.
