# CVE-2026-22803: SvelteKit has a memory amplification DoS in Remote Functions binary form deserializer

> Attackers can cause server memory exhaustion and denial of service via crafted payloads in experimental remote functions.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026
- **Updated:** 15 Jan 2026
- **Also known as:** GHSA-j2f3-wq62-6q46

## What is CVE-2026-22803?

CVE-2026-22803 is a high-severity denial of service vulnerability in sveltejs kit, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. From 2.49.0 to 2.49.4, the experimental form remote function uses a binary data format containing a representation of submitted form data. A specially-crafted payload can cause the server to allocate a large amount of memory, causing DoS via memory exhaustion. This vulnerability is fixed in 2.49.5.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-22803?

2 open source packages ship an affected version, including @sveltejs/kit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | From 2.49.0 | 2.49.5 |
| `@sveltejs/kit` | npm | From 2.49.0 | 2.49.5 |

Products: Svelte Kit.

## How do I fix CVE-2026-22803?

Upgrade @sveltejs/kit to 2.49.5 or later.

## Is CVE-2026-22803 being exploited?

There is no known exploitation of CVE-2026-22803 in the wild and no public exploit code.

## Other vulnerabilities in sveltejs kit

- [CVE-2026-40073](https://insights.sbomify.com/CVE-2026-40073/): SvelteKit has a BODY_SIZE_LIMIT bypass in @sveltejs/adapter-node (high 8.2)
- [CVE-2026-40074](https://insights.sbomify.com/CVE-2026-40074/): SvelteKit's invalidated redirect in handle hook causes Denial-of-Service (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22803 and fix it if it is affected.

What it is: CVE-2026-22803 is a high-severity denial of service vulnerability in sveltejs kit, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22803 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected from 2.49.0; fixed in 2.49.5
- @sveltejs/kit (npm): affected from 2.49.0; fixed in 2.49.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22803/ (Markdown: https://insights.sbomify.com/CVE-2026-22803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22803
- OSV: https://osv.dev/vulnerability/CVE-2026-22803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22803/
Summaries are generated and may contain mistakes; the official description above is the record.
