# CVE-2026-22808: Fleet Windows MDM endpoint has a Cross-site Scripting vulnerability

> An unauthenticated attacker can steal admin tokens via XSS in the Windows MDM endpoint, gaining unauthorized access and control over Fleet.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-gfpw-jgvr-cw4j, GO-2026-4336

## What is CVE-2026-22808?

CVE-2026-22808 is a medium-severity cross-site scripting vulnerability in fleetdm fleet, published on 21 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

fleetdm/fleet is open source device management software. Prior to versions 4.78.2, 4.77.1, 4.76.2, 4.75.2, and 4.53.3, if Windows MDM is enabled, an unauthenticated attacker can exploit this XSS vulnerability to steal a Fleet administrator's authentication token (FLEET::auth_token) from localStorage. This could allow unauthorized access to Fleet, including administrative access, visibility into device data, and modification of configuration. Versions 4.78.2, 4.77.1, 4.76.2, 4.75.2, and 4.53.3 fix the issue. If an immediate upgrade is not possible, affected Fleet users should temporarily disable Windows MDM.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-22808?

11 open source packages ship an affected version, including github.com/fleetdm/fleet and github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet` | Go | From 4.75.0 | 4.75.2 |
| `github.com/fleetdm/fleet` | Go | From 4.75.0 | 4.75.2 |
| `github.com/fleetdm/fleet` | Go | From 4.76.0 | 4.76.2 |
| `github.com/fleetdm/fleet` | Go | From 4.76.0 | 4.76.2 |
| `github.com/fleetdm/fleet` | Go | From 4.77.0 | 4.77.1 |
| `github.com/fleetdm/fleet` | Go | From 4.77.0 | 4.77.1 |
| `github.com/fleetdm/fleet` | Go | From 4.78.0 | 4.78.2 |
| `github.com/fleetdm/fleet` | Go | From 4.78.0 | 4.78.2 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.43.5-0.20260111020427-0e6c790803d1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.43.5-0.20260111020427-0e6c790803d1 |
| `github.com/fleetdm/fleet/v4` | Go | From 4.75.0 | 4.75.2, 4.76.2, 4.77.1, 4.78.2 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-22808?

Upgrade github.com/fleetdm/fleet to a fixed version for your release line: 4.75.2, 4.76.2, 4.77.1 or 4.78.2.

## Is CVE-2026-22808 being exploited?

There is no known exploitation of CVE-2026-22808 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22808 and fix it if it is affected.

What it is: CVE-2026-22808 is a medium-severity cross-site scripting vulnerability in fleetdm fleet, published on 21 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-22808 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet (Go): affected from 4.75.0; fixed in 4.75.2
- github.com/fleetdm/fleet (Go): affected from 4.75.0; fixed in 4.75.2
- github.com/fleetdm/fleet (Go): affected from 4.76.0; fixed in 4.76.2
- github.com/fleetdm/fleet (Go): affected from 4.76.0; fixed in 4.76.2
- github.com/fleetdm/fleet (Go): affected from 4.77.0; fixed in 4.77.1
- github.com/fleetdm/fleet (Go): affected from 4.77.0; fixed in 4.77.1
- github.com/fleetdm/fleet (Go): affected from 4.78.0; fixed in 4.78.2
- github.com/fleetdm/fleet (Go): affected from 4.78.0; fixed in 4.78.2
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.43.5-0.20260111020427-0e6c790803d1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.43.5-0.20260111020427-0e6c790803d1
- github.com/fleetdm/fleet/v4 (Go): affected from 4.75.0; fixed in 4.75.2, 4.76.2, 4.77.1, 4.78.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22808/ (Markdown: https://insights.sbomify.com/CVE-2026-22808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22808
- OSV: https://osv.dev/vulnerability/CVE-2026-22808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22808/
Summaries are generated and may contain mistakes; the official description above is the record.
