# CVE-2026-22810: Joplin: Path traversal in OneNote importer allows overwriting arbitrary files

> Attackers can overwrite arbitrary files via malicious OneNote imports due to unsanitized filenames in Joplin.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-gcmj-c9gg-9vh6

## What is CVE-2026-22810?

CVE-2026-22810 is a high-severity path traversal vulnerability in laurent22 joplin, published on 18 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Joplin is an open source note-taking and to-do application that organises notes and lists into notebooks. Versions prior to 3.5.7 contain a path traversal vulnerability in the importer which allows overwriting arbitrary files on disk. The OneNote converter does not sanitize the names of embedded files before writing them to disk. As a result, it's possible for an attacker to create a malicious .one file that includes file names containing ../../, that are then interpreted as part of the target path when extracting attachments from the .one file. This issue has been patched in version 3.5.7.

Weakness: CWE-24 (Path Traversal: '../filedir')

## Which versions are affected by CVE-2026-22810?

2 open source packages ship an affected version, including @joplin/onenote-converter. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@joplin/onenote-converter` | npm | All versions | 3.5.7 |
| `@joplin/onenote-converter` | npm | All versions | 3.5.7 |

Products: Joplinapp Joplin, Msiemens One2html.

## How do I fix CVE-2026-22810?

Upgrade @joplin/onenote-converter to 3.5.7 or later.

## Is CVE-2026-22810 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22810 exists.

## Other vulnerabilities in laurent22 joplin

- [CVE-2022-35131](https://insights.sbomify.com/CVE-2022-35131/): Joplin is vulnerable to arbitrary code execution (critical 9.0)
- [CVE-2022-40277](https://insights.sbomify.com/CVE-2022-40277/): Joplin Remote Code Execution (high 7.8)
- [CVE-2021-23431](https://insights.sbomify.com/CVE-2021-23431/): Cross-site Request Forgery (CSRF) (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22810 and fix it if it is affected.

What it is: CVE-2026-22810 is a high-severity path traversal vulnerability in laurent22 joplin, published on 18 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22810 exists.

Affected packages and fixed versions:
- @joplin/onenote-converter (npm): affected all versions; fixed in 3.5.7
- @joplin/onenote-converter (npm): affected all versions; fixed in 3.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22810/ (Markdown: https://insights.sbomify.com/CVE-2026-22810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22810
- OSV: https://osv.dev/vulnerability/CVE-2026-22810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22810/
Summaries are generated and may contain mistakes; the official description above is the record.
