# CVE-2026-22812: OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution

> An unauthenticated local HTTP server in OpenCode allows arbitrary shell command execution via permissive CORS, requiring an upgrade to secure the tool.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2026
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-vxw4-wv6m-9hhh

## What is CVE-2026-22812?

CVE-2026-22812 is a high-severity command injection vulnerability in anomalyco opencode, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenCode is an open source AI coding agent. Prior to 1.0.216, OpenCode automatically starts an unauthenticated HTTP server that allows any local process (or any website via permissive CORS) to execute arbitrary shell commands with the user's privileges. This vulnerability is fixed in 1.0.216.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-749 (Exposed Dangerous Method or Function), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-22812?

2 open source packages ship an affected version, including opencode-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencode-ai` | npm | All versions | 1.0.216 |
| `opencode-ai` | npm | All versions | 1.0.216 |

Products: Anoma Opencode.

## How do I fix CVE-2026-22812?

Upgrade opencode-ai to 1.0.216 or later.

## Is CVE-2026-22812 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22812 exists.

Public exploit code:

- https://github.com/rohmatariow/CVE-2026-22812-exploit (github_poc): https://github.com/rohmatariow/CVE-2026-22812-exploit
- Security-hardened fork of OpenCode - Fixes CVE-2026-22812 (CVSS 8.8 RCE) that upstream refuses to patch (github_poc): https://github.com/barrersoftware/opencode-secure
- OpenCode  < v1.0.216 - Unauthenticated RCE (github_poc): https://github.com/0xgh057r3c0n/CVE-2026-22812
- CVE-2026-22812 - OpenCode Unauth RCE (github_poc): https://github.com/Udyz/CVE-2026-22812-Exp
- https://github.com/CayberMods/CVE-2026-22812-POC (github_poc): https://github.com/CayberMods/CVE-2026-22812-POC
- Open security research on AI coding agent infrastructure. Agent-executable remediation manifests for CVE-2026-22812 and CVE-2026-22813. (github_poc): https://github.com/HodgeLuke/ai-agent-security-research

## Other vulnerabilities in anomalyco opencode

- [CVE-2026-22813](https://insights.sbomify.com/CVE-2026-22813/): Malicious website can execute commands on the local system through XSS in the OpenCode web UI (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22812 and fix it if it is affected.

What it is: CVE-2026-22812 is a high-severity command injection vulnerability in anomalyco opencode, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22812 exists.

Affected packages and fixed versions:
- opencode-ai (npm): affected all versions; fixed in 1.0.216
- opencode-ai (npm): affected all versions; fixed in 1.0.216

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22812/ (Markdown: https://insights.sbomify.com/CVE-2026-22812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22812
- OSV: https://osv.dev/vulnerability/CVE-2026-22812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22812/
Summaries are generated and may contain mistakes; the official description above is the record.
