# CVE-2026-22813: Malicious website can execute commands on the local system through XSS in the OpenCode web UI

> Attackers can execute arbitrary commands on the local system via XSS in the OpenCode web UI by controlling LLM responses.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2026
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-c83v-7274-4vgp

## What is CVE-2026-22813?

CVE-2026-22813 is a critical cross-site scripting vulnerability in anomalyco opencode, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenCode is an open source AI coding agent. The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via HTML injection. This means controlling the LLM response for a chat session gets JavaScript execution on the http://localhost:4096 origin. This vulnerability is fixed in 1.1.10.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-22813?

2 open source packages ship an affected version, including opencode-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencode-ai` | npm | All versions | 1.1.10 |
| `opencode-ai` | npm | All versions | 1.1.10 |

Products: Anoma Opencode.

## How do I fix CVE-2026-22813?

Upgrade opencode-ai to 1.1.10 or later.

## Is CVE-2026-22813 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22813 exists.

## Other vulnerabilities in anomalyco opencode

- [CVE-2026-22812](https://insights.sbomify.com/CVE-2026-22812/): OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22813 and fix it if it is affected.

What it is: CVE-2026-22813 is a critical cross-site scripting vulnerability in anomalyco opencode, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22813 exists.

Affected packages and fixed versions:
- opencode-ai (npm): affected all versions; fixed in 1.1.10
- opencode-ai (npm): affected all versions; fixed in 1.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22813/ (Markdown: https://insights.sbomify.com/CVE-2026-22813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22813
- OSV: https://osv.dev/vulnerability/CVE-2026-22813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22813/
Summaries are generated and may contain mistakes; the official description above is the record.
