# CVE-2026-22815: AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers

> Attackers can cause denial of service by sending unlimited trailer headers, leading to uncapped memory usage in the aiohttp library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2026
- **Updated:** 4 Apr 2026
- **Also known as:** AZL-81755, CLEANSTART-2026-LM62319, CLEANSTART-2026-PT55755, CLSA-2026-1780274962, DEBIAN-CVE-2026-22815, ECHO-b104-18be-dba6, GHSA-w2fm-2cpv-w7v5, MINI-72mw-4h4w-866j, MINI-8337-h3f9-cr66, MINI-957m-98c7-jc6g, MINI-f4pc-r8g8-gppr, MINI-f782-9f84-9w79, MINI-m2w3-4p63-xh5p, MINI-vm9g-9r62-832q, PYSEC-2026-2094, ROOT-APP-PYPI-CVE-2026-22815, UBUNTU-CVE-2026-22815

## What is CVE-2026-22815?

CVE-2026-22815 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.13.4, insufficient restrictions in header/trailer handling could cause uncapped memory usage. This issue has been patched in version 3.13.4.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-22815?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.13.4 |
| `aiohttp` | PyPI | All versions | 3.13.4 |
| `aiohttp` | PyPI | All versions | 3.13.4 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2026-22815?

Upgrade aiohttp to 3.13.4 or later.

## Is CVE-2026-22815 being exploited?

There is no known exploitation of CVE-2026-22815 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-54273](https://insights.sbomify.com/CVE-2026-54273/): AIOHTTP: HTTP/1 Pipelined Requests Queue Without Limit (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22815 and fix it if it is affected.

What it is: CVE-2026-22815 is a medium-severity denial of service vulnerability in aio-libs aiohttp, published on 1 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22815 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.13.4
- aiohttp (PyPI): affected all versions; fixed in 3.13.4
- aiohttp (PyPI): affected all versions; fixed in 3.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22815/ (Markdown: https://insights.sbomify.com/CVE-2026-22815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22815
- OSV: https://osv.dev/vulnerability/CVE-2026-22815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22815/
Summaries are generated and may contain mistakes; the official description above is the record.
