# CVE-2026-22816: Gradle fails to disable repositories which can expose builds to malicious artifacts

> Attackers can serve malicious artifacts by registering lapsed or typoed repository domains, leading to code execution during builds.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** BELL-CVE-2026-22816, BIT-gradle-2026-22816, DEBIAN-CVE-2026-22816, GHSA-w78c-w6vf-rw82, MINI-3qqw-cf22-vggw, MINI-pj2c-832m-86f4, MINI-q5c9-cfhq-fg3f, UBUNTU-CVE-2026-22816

## What is CVE-2026-22816?

CVE-2026-22816 is a high-severity vulnerability in gradle, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Gradle is a build automation tool, and its native-platform tool provides Java bindings for native APIs. When resolving dependencies in versions before 9.3.0, some exceptions were not treated as fatal errors and would not cause a repository to be disabled. If a build encountered one of these exceptions, Gradle would continue to the next repository in the list and potentially resolve dependencies from a different repository. If a Gradle build used an unresolvable host name, Gradle would continue to work as long as all dependencies could be resolved from another repository. An unresolvable host name could be caused by allowing a repository's domain name registration to lapse or typo-ing the real domain name. This behavior could allow an attacker to register a service under the host name used by the build and serve malicious artifacts. The attack requires the repository to be listed before others in the build configuration. Gradle has introduced a change in behavior in Gradle 9.3.0 to stop searching other repositories when encountering these errors.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2026-22816?

1 open source package ship an affected version, including gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | All versions | 9.3.0 |

Products: Gradle Gradle.

## How do I fix CVE-2026-22816?

Upgrade gradle to 9.3.0 or later.

## Is CVE-2026-22816 being exploited?

There is no known exploitation of CVE-2026-22816 in the wild and no public exploit code.

## Other vulnerabilities in gradle

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2021-29428](https://insights.sbomify.com/CVE-2021-29428/): Local privilege escalation through system temporary directory (high 8.8)
- [CVE-2026-22865](https://insights.sbomify.com/CVE-2026-22865/): Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts (high 8.6)
- [CVE-2021-41588](https://insights.sbomify.com/CVE-2021-41588/): Deserialization in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22816 and fix it if it is affected.

What it is: CVE-2026-22816 is a high-severity vulnerability in gradle, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-22816 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected all versions; fixed in 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22816/ (Markdown: https://insights.sbomify.com/CVE-2026-22816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22816
- OSV: https://osv.dev/vulnerability/CVE-2026-22816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22816/
Summaries are generated and may contain mistakes; the official description above is the record.
