# CVE-2026-22818: JWT algorithm confusion in Hono JWK Auth Middleware when JWK lacks "alg" (untrusted header.alg fallback)

> Attackers can forge JWT tokens to bypass authentication in Hono applications using JWK middleware if the JWK lacks an explicit algorithm definition.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2026
- **Updated:** 15 Jan 2026
- **Also known as:** GHSA-3vhc-576x-3qv4, MINI-g76w-r7h6-cv94, MINI-m762-j559-89gq

## What is CVE-2026-22818?

CVE-2026-22818 is a high-severity authentication bypass vulnerability in honojs hono, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.11.4, there is a flaw in Hono’s JWK/JWKS JWT verification middleware allowed the algorithm specified in the JWT header to influence signature verification when the selected JWK did not explicitly define an algorithm. This could enable JWT algorithm confusion and, in certain configurations, allow forged tokens to be accepted. The JWK/JWKS JWT verification middleware has been updated to require an explicit allowlist of asymmetric algorithms when verifying tokens. The middleware no longer derives the verification algorithm from untrusted JWT header values. This vulnerability is fixed in 4.11.4.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-22818?

2 open source packages ship an affected version, including hono. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | All versions | 4.11.4 |
| `hono` | npm | All versions | 4.11.4 |

Products: Hono Hono.

## How do I fix CVE-2026-22818?

Upgrade hono to 4.11.4 or later.

## Is CVE-2026-22818 being exploited?

There is no known exploitation of CVE-2026-22818 in the wild and no public exploit code.

## Other vulnerabilities in honojs hono

- [CVE-2026-27700](https://insights.sbomify.com/CVE-2026-27700/): Hono is Vulnerable to Authentication Bypass by IP Spoofing in AWS Lambda ALB conninfo (high 8.2)
- [CVE-2026-22817](https://insights.sbomify.com/CVE-2026-22817/): JWT Algorithm Confusion via Unsafe Default (HS256) in Hono JWT Middleware Allows Token Forgery and Auth Bypass (high 8.2)
- [CVE-2025-62610](https://insights.sbomify.com/CVE-2025-62610/): Hono Improperly Authorizes JWT Audience Validation (high 8.1)
- [CVE-2026-29045](https://insights.sbomify.com/CVE-2026-29045/): Hono: Arbitrary file access via serveStatic vulnerability (high 7.5)
- [CVE-2025-58362](https://insights.sbomify.com/CVE-2025-58362/): Hono contains a flaw in URL path parsing, potentially leading to path confusion (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22818 and fix it if it is affected.

What it is: CVE-2026-22818 is a high-severity authentication bypass vulnerability in honojs hono, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22818 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected all versions; fixed in 4.11.4
- hono (npm): affected all versions; fixed in 4.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22818/ (Markdown: https://insights.sbomify.com/CVE-2026-22818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22818
- OSV: https://osv.dev/vulnerability/CVE-2026-22818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22818/
Summaries are generated and may contain mistakes; the official description above is the record.
