# CVE-2026-22819: Outray has a Race Condition in main/apps/web/src/routes/api/$orgSlug/subdomains/index.ts

> A race condition in Outray allows free-tier users to bypass subdomain limits by exploiting missing database transaction locks.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2026
- **Updated:** 14 Jan 2026
- **Also known as:** GHSA-45hj-9x76-wp9g

## What is CVE-2026-22819?

CVE-2026-22819 is a medium-severity vulnerability in akinloluwami outray, published on 14 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Outray openSource ngrok alternative. Prior to 0.1.5, this vulnerability allows a user i.e a free plan user to get more than the desired subdomains due to lack of db transaction lock mechanisms in main/apps/web/src/routes/api/$orgSlug/subdomains/index.ts. This vulnerability is fixed in 0.1.5.

Weakness: CWE-366 (Race Condition within a Thread)

## Which versions are affected by CVE-2026-22819?

2 open source packages ship an affected version, including outray. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `outray` | npm | All versions | 0.1.5 |
| `outray` | npm | All versions | 0.1.5 |

Products: Outray Outray.

## How do I fix CVE-2026-22819?

Upgrade outray to 0.1.5 or later.

## Is CVE-2026-22819 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22819 exists.

## Other vulnerabilities in akinloluwami outray

- [CVE-2026-22820](https://insights.sbomify.com/CVE-2026-22820/): Outray cli is vulnerable to race conditions in tunnels creation (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22819 and fix it if it is affected.

What it is: CVE-2026-22819 is a medium-severity vulnerability in akinloluwami outray, published on 14 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22819 exists.

Affected packages and fixed versions:
- outray (npm): affected all versions; fixed in 0.1.5
- outray (npm): affected all versions; fixed in 0.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22819/ (Markdown: https://insights.sbomify.com/CVE-2026-22819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22819
- OSV: https://osv.dev/vulnerability/CVE-2026-22819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22819/
Summaries are generated and may contain mistakes; the official description above is the record.
