# CVE-2026-22820: Outray cli is vulnerable to race conditions in tunnels creation

> Attackers can exploit a race condition to create more tunnels than allowed by their subscription plan, bypassing usage limits.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2026
- **Updated:** 14 Jan 2026
- **Also known as:** GHSA-3pqc-836w-jgr7

## What is CVE-2026-22820?

CVE-2026-22820 is a medium-severity vulnerability in akinloluwami outray, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Outray openSource ngrok alternative. Prior to 0.1.5, a TOCTOU race condition vulnerability allows a user to exceed the set number of active tunnels in their subscription plan. This vulnerability is fixed in 0.1.5.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-22820?

2 open source packages ship an affected version, including outray. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `outray` | npm | All versions | 0.1.5 |
| `outray` | npm | All versions | 0.1.5 |

Products: Outray Outray.

## How do I fix CVE-2026-22820?

Upgrade outray to 0.1.5 or later.

## Is CVE-2026-22820 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22820 exists.

## Other vulnerabilities in akinloluwami outray

- [CVE-2026-22819](https://insights.sbomify.com/CVE-2026-22819/): Outray has a Race Condition in main/apps/web/src/routes/api/$orgSlug/subdomains/index.ts (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22820 and fix it if it is affected.

What it is: CVE-2026-22820 is a medium-severity vulnerability in akinloluwami outray, published on 14 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22820 exists.

Affected packages and fixed versions:
- outray (npm): affected all versions; fixed in 0.1.5
- outray (npm): affected all versions; fixed in 0.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22820/ (Markdown: https://insights.sbomify.com/CVE-2026-22820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22820
- OSV: https://osv.dev/vulnerability/CVE-2026-22820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22820/
Summaries are generated and may contain mistakes; the official description above is the record.
