# CVE-2026-22821: mreporting affected by a SQLI on date change

> An attacker can perform SQL injection via date change parameters in the mreporting GLPI plugin, potentially reading or modifying database contents.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** GHSA-24q7-h59q-33w8

## What is CVE-2026-22821?

CVE-2026-22821 is a medium-severity SQL injection vulnerability in pluginsGLPI mreporting, published on 12 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

mreporting is the more reporting GLPI plugin. Prior to 1.9.4, there is a possible SQL injection on date change. This vulnerability is fixed in 1.9.4.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-22821?

It affects 1 product.


Products: Glpi-Project More Reporting.

## How do I fix CVE-2026-22821?

No fix has been published for CVE-2026-22821 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-22821 being exploited?

There is no known exploitation of CVE-2026-22821 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22821 and fix it if it is affected.

What it is: CVE-2026-22821 is a medium-severity SQL injection vulnerability in pluginsGLPI mreporting, published on 12 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22821 in the wild and no public exploit code.

Affected product: pluginsGLPI mreporting. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22821/ (Markdown: https://insights.sbomify.com/CVE-2026-22821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22821
- OSV: https://osv.dev/vulnerability/CVE-2026-22821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22821/
Summaries are generated and may contain mistakes; the official description above is the record.
