# CVE-2026-22863: Deno node:crypto doesn't finalize cipher

> Attackers can exploit incomplete cipher finalization in Deno's node:crypto to potentially learn server secrets through refined attacks.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026
- **Updated:** 16 Jan 2026
- **Also known as:** GHSA-5379-f5hf-w38v, JLSEC-2026-114

## What is CVE-2026-22863?

CVE-2026-22863 is a critical vulnerability in denoland deno, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Before 2.6.0, node:crypto doesn't finalize cipher. The vulnerability allows an attacker to have infinite encryptions. This can lead to naive attempts at brute forcing, as well as more refined attacks with the goal to learn the server secrets. This vulnerability is fixed in 2.6.0.

Weakness: CWE-325 (Missing Cryptographic Step)

## Which versions are affected by CVE-2026-22863?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | All versions | 2.6.0 |
| `deno` | crates.io | All versions | 2.6.0 |

Products: Deno Deno.

## How do I fix CVE-2026-22863?

Upgrade deno to 2.6.0 or later.

## Is CVE-2026-22863 being exploited?

There is no known exploitation of CVE-2026-22863 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)
- [CVE-2023-28446](https://insights.sbomify.com/CVE-2023-28446/): Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22863 and fix it if it is affected.

What it is: CVE-2026-22863 is a critical vulnerability in denoland deno, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22863 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected all versions; fixed in 2.6.0
- deno (crates.io): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22863/ (Markdown: https://insights.sbomify.com/CVE-2026-22863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22863
- OSV: https://osv.dev/vulnerability/CVE-2026-22863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22863/
Summaries are generated and may contain mistakes; the official description above is the record.
