# CVE-2026-22864: Deno has an incomplete fix for command-injection prevention on Windows — case-insensitive extension bypass

> Attackers can bypass command injection protections in Deno on Windows by using case-insensitive file extensions to execute arbitrary commands.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026
- **Updated:** 16 Jan 2026
- **Also known as:** GHSA-m3c4-prhw-mrx6, JLSEC-2026-115

## What is CVE-2026-22864?

CVE-2026-22864 is a high-severity command injection vulnerability in denoland deno, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Before 2.5.6, a prior patch aimed to block spawning Windows batch/shell files by returning an error when a spawned path’s extension matched .bat or .cmd. That check performs a case-sensitive comparison against lowercase literals and therefore can be bypassed when the extension uses alternate casing (for example .BAT, .Bat, etc.). This vulnerability is fixed in 2.5.6.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-22864?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | All versions | 2.5.6 |
| `deno` | crates.io | All versions | 2.5.6 |

Products: Deno Deno.

## How do I fix CVE-2026-22864?

Upgrade deno to 2.5.6 or later.

## Is CVE-2026-22864 being exploited?

There is no known exploitation of CVE-2026-22864 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22864 and fix it if it is affected.

What it is: CVE-2026-22864 is a high-severity command injection vulnerability in denoland deno, published on 15 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-22864 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected all versions; fixed in 2.5.6
- deno (crates.io): affected all versions; fixed in 2.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22864/ (Markdown: https://insights.sbomify.com/CVE-2026-22864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22864
- OSV: https://osv.dev/vulnerability/CVE-2026-22864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22864/
Summaries are generated and may contain mistakes; the official description above is the record.
