# CVE-2026-22865: Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts

> Attackers can disrupt a repository to force Gradle to fetch malicious artifacts from a secondary repository, leading to code execution.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** BELL-CVE-2026-22865, BIT-gradle-2026-22865, DEBIAN-CVE-2026-22865, GHSA-mqwm-5m85-gmcv, MINI-3qrp-9jhc-jm3p, MINI-4x9v-mpj9-p8g8, MINI-6g6g-7hfh-mff8, UBUNTU-CVE-2026-22865

## What is CVE-2026-22865?

CVE-2026-22865 is a high-severity vulnerability in gradle, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Gradle is a build automation tool, and its native-platform tool provides Java bindings for native APIs. When resolving dependencies in versions before 9.3.0, some exceptions were not treated as fatal errors and would not cause a repository to be disabled. If a build encountered one of these exceptions, Gradle would continue to the next repository in the list and potentially resolve dependencies from a different repository. An exception like NoHttpResponseException can indicate transient errors. If the errors persist after a maximum number of retries, Gradle would continue to the next repository. This behavior could allow an attacker to disrupt the service of a repository and leverage another repository to serve malicious artifacts. This attack requires the attacker to have control over a repository after the disrupted repository. Gradle has introduced a change in behavior in Gradle 9.3.0 to stop searching other repositories when encountering these errors.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2026-22865?

1 open source package ship an affected version, including gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gradle` | Bitnami | All versions | 9.3.0 |

Products: Gradle Gradle.

## How do I fix CVE-2026-22865?

Upgrade gradle to 9.3.0 or later.

## Is CVE-2026-22865 being exploited?

There is no known exploitation of CVE-2026-22865 in the wild and no public exploit code.

## Other vulnerabilities in gradle

- [CVE-2019-15052](https://insights.sbomify.com/CVE-2019-15052/): Information disclosure in n/a (critical 9.8)
- [CVE-2016-6199](https://insights.sbomify.com/CVE-2016-6199/): Deserialization in n/a (critical 9.8)
- [CVE-2021-29428](https://insights.sbomify.com/CVE-2021-29428/): Local privilege escalation through system temporary directory (high 8.8)
- [CVE-2026-22816](https://insights.sbomify.com/CVE-2026-22816/): Gradle fails to disable repositories which can expose builds to malicious artifacts (high 8.6)
- [CVE-2021-41588](https://insights.sbomify.com/CVE-2021-41588/): Deserialization in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22865 and fix it if it is affected.

What it is: CVE-2026-22865 is a high-severity vulnerability in gradle, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-22865 in the wild and no public exploit code.

Affected packages and fixed versions:
- gradle (Bitnami): affected all versions; fixed in 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22865/ (Markdown: https://insights.sbomify.com/CVE-2026-22865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22865
- OSV: https://osv.dev/vulnerability/CVE-2026-22865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22865/
Summaries are generated and may contain mistakes; the official description above is the record.
