# CVE-2026-22870: GuardDog Zip Bomb Vulnerability in safe_extract() Allows DoS


- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Jan 2026
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-ffj4-jq7m-9g6v, PYSEC-2026-1429

## What is CVE-2026-22870?

CVE-2026-22870 is a high-severity vulnerability in DataDog guarddog, published on 13 Jan 2026. 

### Official description

GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, GuardDog's safe_extract() function does not validate decompressed file sizes when extracting ZIP archives (wheels, eggs), allowing attackers to cause denial of service through zip bombs. A malicious package can consume gigabytes of disk space from a few megabytes of compressed data. This vulnerability is fixed in 2.7.1.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-22870?

3 open source packages ship an affected version, including guarddog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guarddog` | PyPI | All versions | 2.7.1 |
| `guarddog` | PyPI | All versions | 2.7.1 |
| `guarddog` | PyPI | All versions | 2.7.1 |

Products: Datadoghq Guarddog.

## How do I fix CVE-2026-22870?

Upgrade guarddog to 2.7.1 or later.

## Is CVE-2026-22870 being exploited?

There is no known exploitation of CVE-2026-22870 in the wild and no public exploit code.

## Other vulnerabilities in DataDog guarddog

- [CVE-2026-22871](https://insights.sbomify.com/CVE-2026-22871/): GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE (high 8.7)
- [CVE-2022-23530](https://insights.sbomify.com/CVE-2022-23530/): GuardDog vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package (medium 5.8)
- [CVE-2022-23531](https://insights.sbomify.com/CVE-2022-23531/): Arbitrary file write when scanning a specially-crafted local PyPI package (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22870 and fix it if it is affected.

What it is: CVE-2026-22870 is a high-severity vulnerability in DataDog guarddog, published on 13 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2026-22870 in the wild and no public exploit code.

Affected packages and fixed versions:
- guarddog (PyPI): affected all versions; fixed in 2.7.1
- guarddog (PyPI): affected all versions; fixed in 2.7.1
- guarddog (PyPI): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22870/ (Markdown: https://insights.sbomify.com/CVE-2026-22870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22870
- OSV: https://osv.dev/vulnerability/CVE-2026-22870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22870/
Summaries are generated and may contain mistakes; the official description above is the record.
