{"answers":{"affected":"3 open source packages ship an affected version, including guarddog. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-22871 in the wild and no public exploit code.","fix":"Upgrade guarddog to 2.7.1 or later.","what":"CVE-2026-22871 is a high-severity path traversal vulnerability in DataDog guarddog, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-22871 and fix it if it is affected.\n\nWhat it is: CVE-2026-22871 is a high-severity path traversal vulnerability in DataDog guarddog, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-22871 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- guarddog (PyPI): affected all versions; fixed in 2.7.1\n- guarddog (PyPI): affected all versions; fixed in 2.7.1\n- guarddog (PyPI): affected all versions; fixed in 2.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-22871/ (Markdown: https://insights.sbomify.com/CVE-2026-22871/index.md)","id":"CVE-2026-22871","markdown":"https://insights.sbomify.com/CVE-2026-22871/index.md","name":"CVE-2026-22871","record":{"aliases":["GHSA-xg9w-vg3g-6m68","PYSEC-2026-1430"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PyPI security tool","requires_auth":"none","summary":"Attackers can exploit path traversal in GuardDog to overwrite arbitrary files and execute remote code via malicious PyPI packages.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"guarddog","vendor":"datadoghq"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, there is a path traversal vulnerability exists in GuardDog's safe_extract() function that allows malicious PyPI packages to write arbitrary files outside the intended extraction directory, leading to Arbitrary File Overwrite and Remote Code Execution on systems running GuardDog. This vulnerability is fixed in 2.7.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE","id":"CVE-2026-22871","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Capsule TenantResource RawItems Cluster-Scoped Resource Creation Vulnerability","id":"CVE-2026-22872"},"packages":[{"ecosystem":"PyPI","fixed":["2.7.1"],"introduced":["0"],"last_affected":[],"package":"guarddog","purl":null,"source":"GHSA-xg9w-vg3g-6m68"},{"ecosystem":"PyPI","fixed":["2.7.1"],"introduced":["0"],"last_affected":[],"package":"guarddog","purl":"pkg:pypi/guarddog","source":"GHSA-xg9w-vg3g-6m68"},{"ecosystem":"PyPI","fixed":["2.7.1"],"introduced":["0"],"last_affected":[],"package":"guarddog","purl":"pkg:pypi/guarddog","source":"PYSEC-2026-1430"}],"prev":{"headline":"GuardDog Zip Bomb Vulnerability in safe_extract() Allows DoS","id":"CVE-2026-22870"},"products":["guarddog"],"published":"2026-01-13","related":[{"cvss_score":7.1,"headline":"GuardDog Zip Bomb Vulnerability in safe_extract() Allows DoS","id":"CVE-2026-22870","kev_date_added":null,"published":"2026-01-13"},{"cvss_score":5.8,"headline":"GuardDog vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package","id":"CVE-2022-23530","kev_date_added":null,"published":"2022-12-16"},{"cvss_score":5.8,"headline":"Arbitrary file write when scanning a specially-crafted local PyPI package","id":"CVE-2022-23531","kev_date_added":null,"published":"2022-12-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-13","vendors":["DataDog"]},"summary":"Attackers can exploit path traversal in GuardDog to overwrite arbitrary files and execute remote code via malicious PyPI packages.","url":"https://insights.sbomify.com/CVE-2026-22871/"}