# CVE-2026-22871: GuardDog Path Traversal Vulnerability Leads to Arbitrary File Overwrite and RCE

> Attackers can exploit path traversal in GuardDog to overwrite arbitrary files and execute remote code via malicious PyPI packages.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jan 2026
- **Updated:** 13 Jan 2026
- **Also known as:** GHSA-xg9w-vg3g-6m68, PYSEC-2026-1430

## What is CVE-2026-22871?

CVE-2026-22871 is a high-severity path traversal vulnerability in DataDog guarddog, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

GuardDog is a CLI tool to identify malicious PyPI packages. Prior to 2.7.1, there is a path traversal vulnerability exists in GuardDog's safe_extract() function that allows malicious PyPI packages to write arbitrary files outside the intended extraction directory, leading to Arbitrary File Overwrite and Remote Code Execution on systems running GuardDog. This vulnerability is fixed in 2.7.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-22871?

3 open source packages ship an affected version, including guarddog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guarddog` | PyPI | All versions | 2.7.1 |
| `guarddog` | PyPI | All versions | 2.7.1 |
| `guarddog` | PyPI | All versions | 2.7.1 |

Products: Datadoghq Guarddog.

## How do I fix CVE-2026-22871?

Upgrade guarddog to 2.7.1 or later.

## Is CVE-2026-22871 being exploited?

There is no known exploitation of CVE-2026-22871 in the wild and no public exploit code.

## Other vulnerabilities in DataDog guarddog

- [CVE-2026-22870](https://insights.sbomify.com/CVE-2026-22870/): GuardDog Zip Bomb Vulnerability in safe_extract() Allows DoS (high 7.1)
- [CVE-2022-23530](https://insights.sbomify.com/CVE-2022-23530/): GuardDog vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package (medium 5.8)
- [CVE-2022-23531](https://insights.sbomify.com/CVE-2022-23531/): Arbitrary file write when scanning a specially-crafted local PyPI package (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22871 and fix it if it is affected.

What it is: CVE-2026-22871 is a high-severity path traversal vulnerability in DataDog guarddog, published on 13 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-22871 in the wild and no public exploit code.

Affected packages and fixed versions:
- guarddog (PyPI): affected all versions; fixed in 2.7.1
- guarddog (PyPI): affected all versions; fixed in 2.7.1
- guarddog (PyPI): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22871/ (Markdown: https://insights.sbomify.com/CVE-2026-22871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22871
- OSV: https://osv.dev/vulnerability/CVE-2026-22871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22871/
Summaries are generated and may contain mistakes; the official description above is the record.
