# CVE-2026-22872: Capsule TenantResource RawItems Cluster-Scoped Resource Creation Vulnerability

> Tenant administrators can escalate privileges to cluster-admin level by creating cluster-scoped resources via the Capsule Controller's RawItems processing logic.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-qjjm-7j9w-pw72, GO-2026-5584

## What is CVE-2026-22872?

CVE-2026-22872 is a medium-severity vulnerability in projectcapsule capsule, published on 1 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Capsule is a multi-tenancy and policy-based framework for Kubernetes. The Capsule Controller runs with cluster-admin privileges. Although the TenantResource RawItems processing logic forcibly sets the namespace, this is ineffective for cluster-scoped resources. Prior to version 0.13.0, tenant administrators can leverage the Controller's elevated privileges to create cluster-scoped resources (such as ClusterRole and ValidatingWebhookConfiguration) that they cannot create directly, achieving cross-tenant privilege escalation and cluster-level attacks. The attack vector has a few limiting factors. This attack requires Tenant Owner privileges and requires Capsule Controller running with cluster-admin privileges (default configuration). Additionally, some clusters may have additional admission controllers blocking malicious resources. Version 0.13.0 patches this issue.

Weakness: CWE-863 (Incorrect Authorization), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-22872?

3 open source packages ship an affected version, including github.com/projectcapsule/capsule. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/projectcapsule/capsule` | Go | All versions | 0.13.0 |
| `github.com/projectcapsule/capsule` | Go | All versions | 0.13.0 |
| `github.com/projectcapsule/capsule` | Go | All versions | 0.13.0 |

Products: Projectcapsule Capsule.

## How do I fix CVE-2026-22872?

Upgrade github.com/projectcapsule/capsule to 0.13.0 or later.

## Is CVE-2026-22872 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22872 exists.

## Other vulnerabilities in projectcapsule capsule

- [CVE-2024-39690](https://insights.sbomify.com/CVE-2024-39690/): Capsule tenant owner with "patch namespace" permission can hijack system namespaces (high 8.5)
- [CVE-2026-30963](https://insights.sbomify.com/CVE-2026-30963/): Capsule Namespace Hijacking via subresource (low 3.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-22872 and fix it if it is affected.

What it is: CVE-2026-22872 is a medium-severity vulnerability in projectcapsule capsule, published on 1 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-22872 exists.

Affected packages and fixed versions:
- github.com/projectcapsule/capsule (Go): affected all versions; fixed in 0.13.0
- github.com/projectcapsule/capsule (Go): affected all versions; fixed in 0.13.0
- github.com/projectcapsule/capsule (Go): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-22872/ (Markdown: https://insights.sbomify.com/CVE-2026-22872/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-22872
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-22872
- OSV: https://osv.dev/vulnerability/CVE-2026-22872

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-22872/
Summaries are generated and may contain mistakes; the official description above is the record.
