CVE-2026-22892 Insufficient Authorization in Mattermost Jira Plugin Allows Unauthorized Access to Post Attachments
An authenticated attacker can read post content and attachments from inaccessible channels via the Jira plugin's create-issue endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-22892?
CVE-2026-22892 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 13 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.1.x <= 11.1.2, 10.11.x <= 10.11.9, 11.2.x <= 11.2.1 fail to validate user permissions when creating Jira issues from Mattermost posts, which allows an authenticated attacker with access to the Jira plugin to read post content and attachments from channels they do not have access to via the /create-issue API endpoint by providing the post ID of an inaccessible post.. Mattermost Advisory ID: MMSA-2025-00550
Weakness: CWE-863
Which versions are affected by CVE-2026-22892?
7 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.10 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.10 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.10+incompatible, 11.1.3+incompatible, 11.2.2+incompatible |
github.com/mattermost/mattermost-server Go | From 11.1.0 | 11.1.3 |
github.com/mattermost/mattermost-server Go | From 11.1.0 | 11.1.3 |
github.com/mattermost/mattermost-server Go | From 11.2.0 | 11.2.2 |
1 more packages
github.com/mattermost/mattermost-server Go | From 11.2.0 | 11.2.2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-22892?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.10, 10.11.10+incompatible, 11.1.3+incompatible or 11.2.2+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-22892 being exploited?
There is no known exploitation of CVE-2026-22892 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9pj7-jh2r-87g8, GO-2026-4496.