CVE-2026-2325 Improper Input Validation in MS Teams Meetings API Handler
An authenticated attacker can cause denial of service in Mattermost by sending oversized requests to the meetings API endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2325?
CVE-2026-2325 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to limit the size of the request body on the start meeting API endpoint, which allows an authenticated attacker to cause resource exhaustion or denial of service via a crafted oversized HTTP POST request to {{/api/v1/meetings}}.. Mattermost Advisory ID: MMSA-2026-00608
Weakness: CWE-770
Which versions are affected by CVE-2026-2325?
10 open source packages ship an affected version, including github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-plugin-msteams-meetings. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
4 more packages
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-plugin-msteams-meetings Go | All versions | 1.1.1-0.20260213105619-c5892dd169de |
github.com/mattermost/mattermost-plugin-msteams-meetings Go | All versions | 1.1.1-0.20260213105619-c5892dd169de |
github.com/mattermost/mattermost-plugin-msteams-meetings Go | All versions | 1.1.1-0.20260213105619-c5892dd169de |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-2325?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.14, 10.11.14+incompatible, 11.4.4+incompatible or 11.5.2+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-2325 being exploited?
There is no known exploitation of CVE-2026-2325 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-m3p3-8frq-q7qh, GO-2026-5489.