# CVE-2026-2325: Improper Input Validation in MS Teams Meetings API Handler

> An authenticated attacker can cause denial of service in Mattermost by sending oversized requests to the meetings API endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-m3p3-8frq-q7qh, GO-2026-5489

## What is CVE-2026-2325?

CVE-2026-2325 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to limit the size of the request body on the start meeting API endpoint, which allows an authenticated attacker to cause resource exhaustion or denial of service via a crafted oversized HTTP POST request to {{/api/v1/meetings}}.. Mattermost Advisory ID: MMSA-2026-00608

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-2325?

10 open source packages ship an affected version, including github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-plugin-msteams-meetings. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.14 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.14 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible |
| `github.com/mattermost/mattermost-server` | Go | From 11.4.0 | 11.4.4 |
| `github.com/mattermost/mattermost-server` | Go | From 11.4.0 | 11.4.4 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.2 |
| `github.com/mattermost/mattermost-server` | Go | From 11.5.0 | 11.5.2 |
| `github.com/mattermost/mattermost-plugin-msteams-meetings` | Go | All versions | 1.1.1-0.20260213105619-c5892dd169de |
| `github.com/mattermost/mattermost-plugin-msteams-meetings` | Go | All versions | 1.1.1-0.20260213105619-c5892dd169de |
| `github.com/mattermost/mattermost-plugin-msteams-meetings` | Go | All versions | 1.1.1-0.20260213105619-c5892dd169de |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-2325?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.14, 10.11.14+incompatible, 11.4.4+incompatible or 11.5.2+incompatible.

## Is CVE-2026-2325 being exploited?

There is no known exploitation of CVE-2026-2325 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2325 and fix it if it is affected.

What it is: CVE-2026-2325 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2325 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.14
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.14
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0+incompatible; fixed in 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible
- github.com/mattermost/mattermost-server (Go): affected from 11.4.0; fixed in 11.4.4
- github.com/mattermost/mattermost-server (Go): affected from 11.4.0; fixed in 11.4.4
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.2
- github.com/mattermost/mattermost-server (Go): affected from 11.5.0; fixed in 11.5.2
- github.com/mattermost/mattermost-plugin-msteams-meetings (Go): affected all versions; fixed in 1.1.1-0.20260213105619-c5892dd169de
- github.com/mattermost/mattermost-plugin-msteams-meetings (Go): affected all versions; fixed in 1.1.1-0.20260213105619-c5892dd169de
- github.com/mattermost/mattermost-plugin-msteams-meetings (Go): affected all versions; fixed in 1.1.1-0.20260213105619-c5892dd169de

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2325/ (Markdown: https://insights.sbomify.com/CVE-2026-2325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2325
- OSV: https://osv.dev/vulnerability/CVE-2026-2325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2325/
Summaries are generated and may contain mistakes; the official description above is the record.
