CVE-2026-2327 markdown-it is has a Regular Expression Denial of Service (ReDoS)

Medium 6.9 Published Updated

An attacker can cause a denial of service in markdown-it by supplying crafted input that triggers excessive regex backtracking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-2327?

CVE-2026-2327 is a medium-severity denial of service vulnerability in markdown-it, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Versions of the package markdown-it from 13.0.0 and before 14.1.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of the regex /\*+$/ in the linkify function. An attacker can supply a long sequence of * characters followed by a non-matching character, which triggers excessive backtracking and may lead to a denial-of-service condition.

Weakness: CWE-1333

Which versions are affected by CVE-2026-2327?

2 open source packages ship an affected version, including markdown-it. It affects 1 product.

PackageAffectedFixed in
markdown-it npmFrom 13.0.014.1.1
markdown-it npmFrom 13.0.014.1.1

Products include Markdown-It Project Markdown-It.

How do I fix CVE-2026-2327?

Upgrade markdown-it to 14.1.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-2327 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2327 exists.

Sources

Also known as CLEANSTART-2026-BO70828, CLEANSTART-2026-PN19666, CLSA-2026-1774225205, ECHO-1dc3-49dc-a4e2, GHSA-38c4-r59v-3vqw, MINI-37qg-w249-w28g and 12 more.

Is CVE-2026-2327 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free