# CVE-2026-2327: markdown-it is has a Regular Expression Denial of Service (ReDoS)

> An attacker can cause a denial of service in markdown-it by supplying crafted input that triggers excessive regex backtracking.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** CLEANSTART-2026-BO70828, CLEANSTART-2026-PN19666, CLSA-2026-1774225205, ECHO-1dc3-49dc-a4e2, GHSA-38c4-r59v-3vqw, MINI-37qg-w249-w28g, MINI-7c5w-fh74-25gw, MINI-8vx5-63m6-m7fw, MINI-fhmm-jjv6-m46h, MINI-fq8w-hmmh-v58r, MINI-j84g-q6vq-hjq8, MINI-ph9h-3vx3-wf9v, MINI-r3wm-8339-3xgx, MINI-rrm2-mwv3-g9cm, MINI-rx68-fv3f-hfrg, MINI-xxq4-6593-m7x3, ROOT-APP-NPM-CVE-2026-2327, UBUNTU-CVE-2026-2327

## What is CVE-2026-2327?

CVE-2026-2327 is a medium-severity denial of service vulnerability in markdown-it, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package markdown-it from 13.0.0 and before 14.1.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of the regex /\*+$/ in the linkify function. An attacker can supply a long sequence of * characters followed by a non-matching character, which triggers excessive backtracking and may lead to a denial-of-service condition.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-2327?

2 open source packages ship an affected version, including markdown-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `markdown-it` | npm | From 13.0.0 | 14.1.1 |
| `markdown-it` | npm | From 13.0.0 | 14.1.1 |

Products: Markdown-It Project Markdown-It.

## How do I fix CVE-2026-2327?

Upgrade markdown-it to 14.1.1 or later.

## Is CVE-2026-2327 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2327 exists.

## Other vulnerabilities in markdown-it

- [CVE-2025-7969](https://insights.sbomify.com/CVE-2025-7969/): Markdown-it 14.1.0 - Cross-site scripting (XSS) (medium 6.9)
- [CVE-2026-48988](https://insights.sbomify.com/CVE-2026-48988/): markdown-it: Quadratic complexity DoS in smartquotes rule via replaceAt string operations (medium 5.3)
- [CVE-2022-21670](https://insights.sbomify.com/CVE-2022-21670/): Uncontrolled Resource Consumption in markdown-it (medium 5.3)
- [CVE-2015-3295](https://insights.sbomify.com/CVE-2015-3295/): Cross-site scripting in n/a (medium 5.3)
- [CVE-2015-10005](https://insights.sbomify.com/CVE-2015-10005/): markdown-it html_re.js redos (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2327 and fix it if it is affected.

What it is: CVE-2026-2327 is a medium-severity denial of service vulnerability in markdown-it, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2327 exists.

Affected packages and fixed versions:
- markdown-it (npm): affected from 13.0.0; fixed in 14.1.1
- markdown-it (npm): affected from 13.0.0; fixed in 14.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2327/ (Markdown: https://insights.sbomify.com/CVE-2026-2327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2327
- OSV: https://osv.dev/vulnerability/CVE-2026-2327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2327/
Summaries are generated and may contain mistakes; the official description above is the record.
