{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-2348 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-2348 is a medium-severity cross-site scripting vulnerability in Drupal Quick Edit, published on 25 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-2348 and fix it if it is affected.\n\nWhat it is: CVE-2026-2348 is a medium-severity cross-site scripting vulnerability in Drupal Quick Edit, published on 25 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-2348 in the wild and no public exploit code.\n\nAffected product: Drupal Quick Edit. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-2348/ (Markdown: https://insights.sbomify.com/CVE-2026-2348/index.md)","id":"CVE-2026-2348","markdown":"https://insights.sbomify.com/CVE-2026-2348/index.md","name":"CVE-2026-2348","record":{"aliases":["DRUPAL-CONTRIB-2026-009","GHSA-vmwp-f54q-chhh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Quick Edit","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into Drupal pages via the Quick Edit module, potentially compromising user sessions or site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"quick_edit","vendor":"wim-leers"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation (\"Cross-site Scripting\") vulnerability in Drupal Quick Edit allows Cross-Site Scripting (XSS).This issue affects Quick Edit: from 0.0.0 before 1.0.5, from 2.0.0 before 2.0.1.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Quick Edit - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-009","id":"CVE-2026-2348","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"UI Icons - Critical - Cross-site Scripting - SA-CONTRIB-2026-010","id":"CVE-2026-2349"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.0.5","2.0.1"],"introduced":["0","2.0.0"],"last_affected":[],"package":"drupal/quickedit","purl":"pkg:composer/drupal/quickedit?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2026-009"}],"prev":{"headline":"IDOR in Akıllı Ticaret's E-Commerce Pack","id":"CVE-2026-2347"},"products":["Quick Edit"],"published":"2026-03-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-26","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into Drupal pages via the Quick Edit module, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2026-2348/"}