{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23489 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-23489 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-23489 is a critical code injection vulnerability in pluginsGLPI fields, published on 16 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23489 and fix it if it is affected.\n\nWhat it is: CVE-2026-23489 is a critical code injection vulnerability in pluginsGLPI fields, published on 16 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23489 in the wild and no public exploit code.\n\nAffected product: pluginsGLPI fields. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23489/ (Markdown: https://insights.sbomify.com/CVE-2026-23489/index.md)","id":"CVE-2026-23489","markdown":"https://insights.sbomify.com/CVE-2026-23489/index.md","name":"CVE-2026-23489","record":{"aliases":["GHSA-rj7q-mmx9-fhq7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GLPI plugin","requires_auth":"high_privilege","summary":"An attacker with dropdown creation privileges can execute arbitrary PHP code in the Fields plugin for GLPI.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fields","vendor":"teclib-edition"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Fields is a GLPI plugin that allows users to add custom fields on GLPI items forms. Prior to version 1.23.3, it is possible to execute arbitrary PHP code from users that are allowed to create dropdowns. This issue has been patched in version 1.23.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2026-08-05","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-08-05T13:09:55Z","kind":"github_poc","ref":"https://github.com/eorll-lgtm/poc-CVE-2026-23489","stars":0,"title":"Proof of concept (POC) for CVE-2026-23489 GLPI \"Fields\" plugin \u003c= 1.23.2"}],"tier":"poc_unverified"},"has_fix":false,"headline":"Fields GLPI plugin vulnerable to RCE in dropdown generation","id":"CVE-2026-23489","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"pyasn1 has a DoS vulnerability in decoder","id":"CVE-2026-23490"},"packages":[],"prev":{"headline":"Blinko: multiple interfaces in the comment feature allow unauthorized access","id":"CVE-2026-23488"},"products":["fields"],"published":"2026-03-16","related":[{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-12723","kev_date_added":null,"published":"2019-07-10"},{"cvss_score":6.5,"headline":"Fields GLPI plugin vulnerable to unauthorized write access to additional fields","id":"CVE-2023-28855","kev_date_added":null,"published":"2023-04-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-16","vendors":["pluginsGLPI"]},"summary":"An attacker with dropdown creation privileges can execute arbitrary PHP code in the Fields plugin for GLPI.","url":"https://insights.sbomify.com/CVE-2026-23489/"}