# CVE-2026-23489: Fields GLPI plugin vulnerable to RCE in dropdown generation

> An attacker with dropdown creation privileges can execute arbitrary PHP code in the Fields plugin for GLPI.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-rj7q-mmx9-fhq7

## What is CVE-2026-23489?

CVE-2026-23489 is a critical code injection vulnerability in pluginsGLPI fields, published on 16 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Fields is a GLPI plugin that allows users to add custom fields on GLPI items forms. Prior to version 1.23.3, it is possible to execute arbitrary PHP code from users that are allowed to create dropdowns. This issue has been patched in version 1.23.3.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-23489?

It affects 1 product.


Products: Teclib-Edition Fields.

## How do I fix CVE-2026-23489?

No fix has been published for CVE-2026-23489 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-23489 being exploited?

There is no known exploitation of CVE-2026-23489 in the wild and no public exploit code.

Public exploit code:

- Proof of concept (POC) for CVE-2026-23489 GLPI "Fields" plugin <= 1.23.2 (github_poc): https://github.com/eorll-lgtm/poc-CVE-2026-23489

## Other vulnerabilities in pluginsGLPI fields

- [CVE-2019-12723](https://insights.sbomify.com/CVE-2019-12723/): SQL injection in n/a (critical 9.8)
- [CVE-2023-28855](https://insights.sbomify.com/CVE-2023-28855/): Fields GLPI plugin vulnerable to unauthorized write access to additional fields (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23489 and fix it if it is affected.

What it is: CVE-2026-23489 is a critical code injection vulnerability in pluginsGLPI fields, published on 16 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23489 in the wild and no public exploit code.

Affected product: pluginsGLPI fields. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23489/ (Markdown: https://insights.sbomify.com/CVE-2026-23489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23489
- OSV: https://osv.dev/vulnerability/CVE-2026-23489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23489/
Summaries are generated and may contain mistakes; the official description above is the record.
