CVE-2026-23490 pyasn1 has a DoS vulnerability in decoder
An attacker can cause memory exhaustion and denial of service in applications using the pyasn1 library by sending malformed RELATIVE-OID data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23490?
CVE-2026-23490 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 16 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.
Weakness: CWE-770
Which versions are affected by CVE-2026-23490?
3 open source packages ship an affected version, including pyasn1. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
pyasn1 PyPI | From 0.6.1 | 0.6.2 |
pyasn1 PyPI | From 0.6.1 | 0.6.2 |
pyasn1 PyPI | From 0.6.1 | 0.6.2 |
Linux distribution packages (37)
fence-agents-amt-ws AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-apc AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-apc-snmp AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-bladecenter AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-brocade AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-cisco-mds AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-cisco-ucs AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-drac5 AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-eaton-snmp AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-emerson AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-eps AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-heuristics-ping AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-hpblade AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ibm-powervs AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ibm-vpc AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ibmblade AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ifmib AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ilo-moonshot AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ilo-mp AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ilo-ssh AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ilo2 AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-intelmodular AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ipdu AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-ipmilan AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-lpar AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-mpath AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-nutanix-ahv AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-rhevm AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-rsa AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-rsb AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-sbd AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-scsi AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-virsh AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-vmware-rest AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-vmware-soap AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
fence-agents-wti AlmaLinux:10 | All versions | 4.16.0-13.el10_1.2 |
python3-pyasn1 AlmaLinux:10 | All versions | 0.6.2-1.el10_1 |
Products include Debian Debian Linux, Pyasn1 Pyasn1.
How do I fix CVE-2026-23490?
Upgrade pyasn1 to 0.6.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-23490 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23490 exists.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALSA-2026:1903, ALSA-2026:1904, ALSA-2026:1905, ALSA-2026:1906, ALSA-2026:3354, ALSA-2026:3359 and 72 more.