# CVE-2026-23494: Pimcore is Missing Function Level Authorization on "Static Routes" Listing

> An authenticated user without permissions can access the static routes API endpoint to retrieve sensitive configuration data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jan 2026
- **Updated:** 15 Jan 2026
- **Also known as:** GHSA-m3r2-724c-pwgf

## What is CVE-2026-23494?

CVE-2026-23494 is a medium-severity missing authorization vulnerability in Pimcore Pimcore, published on 15 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pimcore is an Open Source Data & Experience Management Platform. Prior to 12.3.1 and 11.5.14, the application fails to enforce proper server-side authorization checks on the API endpoint responsible for reading or listing static routes. In Pimcore, static routes are custom URL patterns defined via the backend interface or the var/config/staticroutes.php file, including details like regex-based patterns, controllers, variables, and priorities. These routes are registered automatically through the PimcoreStaticRoutesBundle and integrated into the MVC routing system. Testing revealed that an authenticated backend user lacking explicit permissions was able to invoke the endpoint (e.g., GET /api/static-routes) and retrieve sensitive route configurations. This vulnerability is fixed in 12.3.1 and 11.5.14.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-23494?

4 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 11.5.14 |
| `pimcore/pimcore` | Packagist | All versions | 11.5.14 |
| `pimcore/pimcore` | Packagist | From 12.0.0-RC1 | 12.3.1 |
| `pimcore/pimcore` | Packagist | From 12.0.0-RC1 | 12.3.1 |

Products: Pimcore Pimcore.

## How do I fix CVE-2026-23494?

Upgrade pimcore/pimcore to a fixed version for your release line: 11.5.14 or 12.3.1.

## Is CVE-2026-23494 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23494 exists.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23494 and fix it if it is affected.

What it is: CVE-2026-23494 is a medium-severity missing authorization vulnerability in Pimcore Pimcore, published on 15 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23494 exists.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 11.5.14
- pimcore/pimcore (Packagist): affected all versions; fixed in 11.5.14
- pimcore/pimcore (Packagist): affected from 12.0.0-RC1; fixed in 12.3.1
- pimcore/pimcore (Packagist): affected from 12.0.0-RC1; fixed in 12.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23494/ (Markdown: https://insights.sbomify.com/CVE-2026-23494/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23494
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23494
- OSV: https://osv.dev/vulnerability/CVE-2026-23494

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23494/
Summaries are generated and may contain mistakes; the official description above is the record.
